Total War Forums

  1. 05-17-2010
    Views:
    81,549
+ Post New Thread
Page 32 of 52 FirstFirst ... 22 30 31 32 33 34 42 ... LastLast
Threads 621 to 640 of 1039

Forum: [Empire: Total War Support Forum]

[A community run and moderated board] Post technical support enquiries here - PLEASE check out the stickies at the top of the forum before posting, thanks!

  1. Sticky Thread Sticky: Read before posting!

    Step 1 - Check first! Search the help stickies and the support section as your issue may be common. Remember, the forum is moderated by...

    Started by DarK‎, 05-27-2010 09:26 AM
    • Replies: 2
    • Views: 15,041
    12-25-2010, 08:13 AM Go to last post
  1. Freeze on Loading Screen

    I've searched the forums and I've seen many people with the same or similar problem, but no solutions. ETW is freezing the entire computer on the...

    Started by annoyed‎, 08-26-2010 06:17 PM
    2 Pages
    1 2
    • Replies: 18
    • Views: 5,017
    08-02-2011, 01:52 PM Go to last post
  2. FPS drops on random fights and requires game restart

    So I picked this game up in the steam summer sale, been a fan of most total war games past and present. The problem I'm experiencing with Empire is...

    Started by Incinerat0r‎, 08-01-2011 08:30 PM
    • Replies: 1
    • Views: 613
    08-02-2011, 02:59 AM Go to last post
  3. Reinforcements Clashed

    I just got the Empire and Napoleon bundle and am enjoying Empire upon my two week old PC very much. I love the Dragoons, within my campaign the 1st...

    Started by tipsypo‎, 07-30-2011 05:39 PM
    • Replies: 2
    • Views: 569
    07-31-2011, 10:04 AM Go to last post
  4. What Settings can I run Empire on?

    Graphics Card: Amd Raedon HD 6870 RAM: 4GB Processor: AMD Athlon II X4 2.80 GHz Screen Res: 1600X900

    Started by Marine27‎, 07-30-2011 06:21 AM
    • Replies: 1
    • Views: 573
    07-30-2011, 06:38 AM Go to last post
  5. ETW high and ultra settings greyed out

    My computer: Alienware m14x windows 7 64bit nvidia geforce GT 555m 3GB Intel(R) Core(TM) i7-2630QM CPU @ 2.00GHz screen resolution: 1600x900...

    Started by chunderdragon‎, 07-24-2011 08:15 PM
    • Replies: 6
    • Views: 3,944
    07-28-2011, 04:40 PM Go to last post
  6. New laptop to support Empire and Napoleon Total War

    Hello! After more than two grueling years having been unable to play Empire since it was first released because of my stupid and slow VAIO, it is...

    Started by Molte87‎, 06-15-2011 04:16 PM
    • Replies: 2
    • Views: 1,338
    07-28-2011, 05:46 AM Go to last post
  7. Question Messed up HUD

    This is my first post on this forum and I really need help on this one. The problem is that while in campaign mode the HUD is just layering up...

    Started by Jimbotheone‎, 06-15-2011 02:01 PM
    • Replies: 1
    • Views: 1,083
    07-27-2011, 05:51 PM Go to last post
  8. Black Screen on Battles

    Everytime i try to load into a battle on Total War: Shogun 2 the screen in black except for the minimap and my bar. I've been reading up all day...

    Started by headhunter5050‎, 07-21-2011 07:24 PM
    • Replies: 3
    • Views: 930
    07-27-2011, 05:43 PM Go to last post
  9. Angry etw blue screen when i try to load into campaign or battle

    my sys specs are: pentium dual core 2.5ghz 2gb ram nvidia geforce 7050/610i chipset(latest drivers i could find for xp downloaded already) 1tb...

    Started by Crowned_Spartan‎, 07-27-2011 05:46 AM
    • Replies: 2
    • Views: 598
    07-27-2011, 05:28 PM Go to last post
  10. Lightbulb WILL NOT EVEN PASS THE 1ST SCREEN - pauses and crashed when i press enter???

    WILL NOT EVEN PASS THE 1ST SCREEN - pauses and crashed when i press enter??? as the title suggest i remember trying the demo a couple of years ago...

    Started by CuorreAzzurro‎, 07-27-2011 09:37 AM
    • Replies: 1
    • Views: 799
    07-27-2011, 12:54 PM Go to last post
  11. Land battles crash

    Hi there, just like allot of people my ETW game tends to crash allot. the difference with most cases and mine is that my game only crashes at land...

    Started by Aart112‎, 07-25-2011 03:22 PM
    • Replies: 0
    • Views: 689
    07-25-2011, 03:22 PM Go to last post
  12. ETW won't start for me anymore

    I had been playing ETW for about a year when I stopped playing for a couple years (work and stuff). Then I tried to play the game again when it told...

    Started by Griff101‎, 07-19-2011 04:09 AM
    2 Pages
    1 2
    • Replies: 13
    • Views: 2,383
    07-23-2011, 06:19 PM Go to last post
  13. cant get empire total war to work on windows 7!

    I have been looking at forums but nothing pops up about my question. what happens is my empire total war freezes at the first thing that pops up. i...

    Started by olly444‎, 07-22-2011 07:21 PM
    • Replies: 6
    • Views: 1,915
    07-23-2011, 04:34 PM Go to last post
  14. Exclamation End turn problem

    Game works fine ! But when I press End Turn button it slows and i need to wait like 1:30 min untill other nations end there turns plz can somewon...

    Started by marrio1‎, 07-20-2011 06:47 PM
    • Replies: 2
    • Views: 1,311
    07-21-2011, 02:55 AM Go to last post
  15. Unhappy Anyway to fix very slow A.I. countries after 1799????

    I enjoy playing past 1799....at least to 1850. My game runs great in the normal 100 years of the game. However, the A.I. countries get so slow once...

    Started by Little_Corsican‎, 01-30-2011 02:48 PM
    • Replies: 7
    • Views: 2,576
    07-20-2011, 07:47 PM Go to last post
  16. Help with game?

    Okay so basically I have Rome: Total war, LOVED IT! So I thought I'd keep an eye out for any other games in the Total War series, I recently found...

    Started by EmpireWarrior‎, 07-18-2011 07:14 PM
    • Replies: 3
    • Views: 921
    07-20-2011, 06:29 AM Go to last post
  17. What is wrong and how do I fix it?

    So i got the imperial splendour mod, it was very good, but I did not know it was mp beta compatible, so i deleted it, and it crashed when i tried to...

    Started by Colonel Kautz‎, 07-17-2011 07:00 AM
    • Replies: 1
    • Views: 571
    07-18-2011, 08:18 AM Go to last post
  18. Cannot install Multiplayer beta due to SEGA PASS site being offline.

    Dear Sir/Madam, My Swedish friend wants to play me at Empire Total war. I have the BETA he can't get it (see title). Please could you give us...

    Started by Monkeyboy33‎, 07-17-2011 02:31 PM
    • Replies: 0
    • Views: 805
    07-17-2011, 02:31 PM Go to last post
  19. Angry Ingame movies lagging

    Hey I have been having this problem for example the duel movies, the revolt movies and the ending victory or defeat movies keep lagging even when I...

    Started by gameman21‎, 01-02-2011 03:57 PM
    • Replies: 5
    • Views: 1,607
    07-16-2011, 12:53 PM Go to last post
  20. Unhappy Years later... still stuttering.

    Hey, I'm an old fan. Been playing the series since Rome, and bought nearly all games with the exception of Napoleon since then. I was happy to buy...

    Started by Kata‎, 06-09-2011 09:16 PM
    • Replies: 6
    • Views: 1,548
    07-15-2011, 07:29 PM Go to last post

+ Post New Thread
Page 32 of 52 FirstFirst ... 22 30 31 32 33 34 42 ... LastLast

Thread Display Options

Use this control to limit the display of threads to those newer than the specified time frame.

Allows you to choose the data by which the thread list will be sorted.

Order threads in...

Note: when sorting by date, 'descending order' will show the newest results first.

Icon Legend

Contains unread posts
Contains unread posts
Contains no unread posts
Contains no unread posts
More than 15 replies or 150 views
Hot thread with unread posts
More than 15 replies or 150 views
Hot thread with no unread posts
Closed Thread
Thread is closed
Thread Contains a Message Written By You
You have posted in this thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts