Total War Forums

Closed Thread
Results 1 to 3 of 3

Thread: Problems with my Shogun 2 Total War

  1. #1
    Junior Member Private
    Join Date
    Mar 2011
    Posts
    1

    Default Problems with my Shogun 2 Total War

    HI everyone,my name is Ilias and Im from Greece.I have some problems with my Shogun 2 Total War.The game sometimes run slow,sometimes I cant login to the game(the game dont start),I cant see in the campaign map the borders,the rivers and the trail of my units when they move..my pc is very good,good game graphics card etc.There is a patch that fix this problems?I have to install the game again (my download took 12 hours...)?Thanks for here me take care.

  2. #2
    Moderator Master and Commander DenmarkRules's Avatar
    Join Date
    Jul 2010
    Location
    Behind you :O
    Posts
    3,008

    Default

    First, you should post here: http://forums.totalwar.com/forumdisp...-Support-Forum
    You should also post your system specs. Even better would be you DxDiag

    "The most amazing things that can happen to a human being will happen to you if you just lower your expectations."

    TOTAL WAR FORUM: TERMS AND CONDITIONS


  3. #3
    Senior Member Master and Commander Shireknight's Avatar
    Join Date
    May 2010
    Location
    Britannia, 70 miles north of Londinium
    Posts
    5,833

    Default

    Please check the support forum -thanks

    It's time for honesty :-
    CA it's time for change, Warscape is fundamentally flawed because it's based on old (bugged) code please retire it and give us a brand new game engine from scratch, until you do this every Total War game is doomed to be bugged before it's even released.



Closed Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts