Total War Forums

+ Reply to Thread
Results 1 to 4 of 4

Thread: Steam won't let me play the game.

  1. #1
    Senior Member Corporal tricky-step's Avatar
    Join Date
    Apr 2011
    Posts
    157

    Default Steam won't let me play the game.

    I receive the following message:

    The game is currently unavailable.
    Please try again at another time.

    How can I fix this and how does this even work? I tried with steam off and online.

  2. #2
    Moderator Master and Commander Billy Ruffian's Avatar
    Join Date
    Jul 2010
    Location
    UK
    Posts
    21,306

    Default

    Try some of these
    FAQ #6

    Common Steam Related Workarounds

    These actions can often solve a "game unavailable" repetitive error in Steam, and are sometimes useful for solving other common problems. Useful as a basis for basic troubleshooting first steps.


    Running Steam as Administrator
    If you are seeing issues with Steam and Steam games, please try the following:
    •Exit from Steam.
    •Right click the Steam.exe from C:\Program Files\Steam or your default location and choose the "Run as Administrator" option to launch Steam. The option may not work with a Desktop shortcut to Steam so be sure to use the direct Steam.exe.
    This process is not permanent. If this corrects your issue, you can continue to launch Steam in this manner or upgrade your Windows User account to Administrator status.

    Verify integrity of game cache
    1.Open Steam
    2.From the My Games tab, right-click on the game and select Properties from the menu.
    3.Select the Local files tab and click the Verify integrity of game cache... button.
    4.Steam will verify the game cache files (GCF's) - this process may take several minutes.
    5.Once the process is completed, the Check Window will automatically exit.

    Deleting Registry.blob
    1. Exit and restart Steam
    2. If the issue persists, exit Steam and delete the clientregistry.blob file under the Steam installation directory (C:\Program Files\Valve\Steam\ by default) and restart Steam
    3. If deleting the clientregistry.blob file does not resolve the issue, please exit Steam and delete everything under the Steam installation directory except Steam.exe and the /SteamApps/ folder - this will force Steam to update when you log in

    Disabling Steam Community
    Another fix for some conditions where TW games won't launch, is to go to steam settings, in-game and disable the Steam community in game.
    Now see if you can launch the game.
    "He uses statistics as a drunken man uses lamp-posts - for support rather than illumination." (Andrew Lang)

    |Takeda| Yokota Takatoshi

    Forum Terms and Conditions

  3. #3
    Shireknight
    Guest

    Default

    moved to tech support

  4. #4
    Junior Member Private Great General Wallace's Avatar
    Join Date
    Sep 2011
    Location
    St. Louis, MO
    Posts
    5

    Default

    I've just downloaded M2 vanilla and Kingdoms in the gold pack from steam and am getting the same error messages. I've tried all of the suggestions from the second post and none have worked. Any other suggestions?

    Also, they do occasionally work and whenever I try restarting Steam it says that it can't shut down steam while Medieval 2: Total War is running even when I had closed the game.

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts