Total War Forums

+ Reply to Thread
Results 1 to 4 of 4

Thread: Low FPS

  1. #1
    Member Private Aristhenes's Avatar
    Join Date
    Mar 2012
    Location
    Sweden
    Posts
    40

    Default Low FPS

    My shogun 2 total war has reeeaaaaaally low fps even during the trailer and the menu, it´s completely unplayable it
    even takes around 15 minutes to start up i don´t know all that computer thingys but i have a gaming computer and i can play WoW and all the other total war games on ultra with 40-60 fps but on shogun 2 and only shogun 2 it has
    completely unplayable FPS. Please help!

  2. #2
    Member Private Aristhenes's Avatar
    Join Date
    Mar 2012
    Location
    Sweden
    Posts
    40

    Default

    I checked my FPS with fraps and shogun runs with 1-6 fps at all times.

  3. #3
    The Creative Assembly Field-Marshall Nicklaus's Avatar
    Join Date
    Oct 2011
    Posts
    2,138
    Formal disclaimer: any views or opinions expressed here are those of the poster and do not necessarily represent the views or opinions of The Creative Assembly or SEGA.

    Quick solutions to common FotS problems :
    http://forums.totalwar.com/showthrea...ed-26-03-2012)

  4. #4
    Tech-Hero. Master and Commander Iscaran's Avatar
    Join Date
    May 2010
    Location
    Bavaria, Germany
    Posts
    4,227

    Default

    AMD FX-CPU ?

    Proper BIOS update ?

    Hotfixes installed ?

    See RBP FAQ #20
    Iscaran

    Hero.

    If you need help with a support request on these boards please read this and follow the instructions.

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts