Total War Forums

+ Reply to Thread
Results 1 to 8 of 8

Thread: Shogun 2 (FotS) settings keep getting on default [Solution - re-run redist files]

  1. #1
    Junior Member Private
    Join Date
    Aug 2011
    Posts
    6

    Default Shogun 2 (FotS) settings keep getting on default [Solution - re-run redist files]

    Hello,

    Whenever I boot my total war after having played the game it puts my settings back to default. (both video and audio). I have no idea how I should fix this, does anyone know how I can solve this problem?

    I have the following hardware:

    Intel 2500K
    nvidia GTX580
    8GB RAM
    and an SSD (128GB Crucial m4) where FOTS is installed.

    Does anyone have a solution?
    (Also my game keeps running on the background, I can only close it with cntrl+alt+delete at processes.)

  2. #2
    The Creative Assembly Field-Marshall Nicklaus's Avatar
    Join Date
    Oct 2011
    Posts
    2,138

    Default

    The settings are only saved when you exit Shogun 2 normally (and when the process shuts down normally). If you are closing with ctrl-alt-del, that is why the settings are reset to default.

    So, with that in mind, let's work out why your game isn't shutting down. This may take some trial and error, so please bear with me. Could you start the game, then exit the game, then wait 2-3 minutes to see if the game stops running the background?
    Formal disclaimer: any views or opinions expressed here are those of the poster and do not necessarily represent the views or opinions of The Creative Assembly or SEGA.

    Quick solutions to common FotS problems :
    http://forums.totalwar.com/showthrea...ed-26-03-2012)

  3. #3
    Junior Member Private
    Join Date
    Aug 2011
    Posts
    6

    Default

    Thanks for the fast response, I just found out that when I close the game with task manager the next time I will boot it it will just closes normally and it keeps the settings. But when I restart my pc and start and close shogun II the same thing will happen again. And also my game doesn't close in 3 minutes it just keeps running.
    Last edited by Game_lordie; 04-30-2012 at 09:51 AM.

  4. #4
    The Creative Assembly Field-Marshall Nicklaus's Avatar
    Join Date
    Oct 2011
    Posts
    2,138

    Default

    Ok, next step:



    Try going to C:\Users\YOURUSERNAME\AppData\Roaming\The Creative Assembly\Shogun2 and delete the following folders:

    army_setups
    battle_preferences
    fx_cache
    ui_cache
    Scripts





    Exit Steam, then go to C:\Program Files (x86)\Steam and delete the following:
    AppUpdateStats.blob
    ClientRegistry.blob

    Then restart Steam (it will update) and try to validate Shogun 2. See if that helps.
    Formal disclaimer: any views or opinions expressed here are those of the poster and do not necessarily represent the views or opinions of The Creative Assembly or SEGA.

    Quick solutions to common FotS problems :
    http://forums.totalwar.com/showthrea...ed-26-03-2012)

  5. #5
    Junior Member Private
    Join Date
    Aug 2011
    Posts
    6

    Default

    There changed only one thing ... after I closed the game from main menu I get a black screen.
    After that game was still running.

  6. #6
    The Creative Assembly Field-Marshall Nicklaus's Avatar
    Join Date
    Oct 2011
    Posts
    2,138

    Default

    Next, try going to : C:\Program Files (x86)\Steam\steamapps\common\total war shogun 2\redist

    Once there, run every .exe, including the one in the directx folder.

    Let me know if that helps.
    Formal disclaimer: any views or opinions expressed here are those of the poster and do not necessarily represent the views or opinions of The Creative Assembly or SEGA.

    Quick solutions to common FotS problems :
    http://forums.totalwar.com/showthrea...ed-26-03-2012)

  7. #7
    Junior Member Private
    Join Date
    Aug 2011
    Posts
    6

    Default

    Works perfectly now, thanks for your help

  8. #8
    The Creative Assembly Field-Marshall Nicklaus's Avatar
    Join Date
    Oct 2011
    Posts
    2,138

    Default

    No problem.
    Formal disclaimer: any views or opinions expressed here are those of the poster and do not necessarily represent the views or opinions of The Creative Assembly or SEGA.

    Quick solutions to common FotS problems :
    http://forums.totalwar.com/showthrea...ed-26-03-2012)

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts