Total War Forums

+ Reply to Thread
Results 1 to 1 of 1

Thread: Rome Total War problem

  1. #1
    Member Private EvilEmperorZoRG GR's Avatar
    Join Date
    Jan 2012
    Location
    Macedonia/Greece
    Posts
    35

    Default Rome Total War problem

    So I'm having problem with Rome too

    My second PC is
    Intel Core 2 Duo E6750 2.6GHz
    2GB Ram DDR2 1066MHz
    GeForce GT 430 1GB DDR3 128bit
    600W L&C
    Monitor Turbo-X 19' {For those wondering, Turbo-X are Greek Laptops, Monitors etc} 1280x1024
    Windows Vista Home Premium 32bit

    Firstly I can't put my resolution higher than 1024x768. I've tried the preferences folder but it didn't help.

    Second problem is the Frame Rate. It's really low {5-20}! I was playing Rome Total War on full settings with a much worse PC. Please help!
    Yes my drivers are updated {although I don't think RTW really needs drivers updating anymore}.
    I'm not playing huge battles, 2000-4000 soldiers.
    Last edited by EvilEmperorZoRG GR; 06-29-2012 at 10:28 AM.
    AMD Phenom x4 Quad Core 2.5GHz 9850 Black Edition
    Diamond Radeon HD 4890 1GB GDDR5 256bit
    4GB {2x2GB} Ram CORSAIR DOMINATOR XMS2-8500 1066MHz
    ASROCK AOD790GX/128M
    Corsair GS 800W
    LG FlatronL192WS 19' 1440x900
    Windows 7 Home Premium 64bit

    LAPTOP - Turbo-X Horizon i5 {Intel Core i5 2410M 2.3-2.9GHz, 4GB DDR3, GeForce GT 540M 1GB, 1366x768, Windows 7 Home Premium 64bit}

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts