Total War Forums

+ Reply to Thread
Results 1 to 2 of 2

Thread: TW games in Windowed Mode

  1. #1
    Senior Member Colonel Leckan's Avatar
    Join Date
    Jul 2010
    Location
    Sweden
    Posts
    793

    Default TW games in Windowed Mode

    This is a little guide on how to play in Windowed Mode in some of the TW games.

    Why would you want to use windowed mode? You can check the web constantly if there is something, like a mail, that you are waiting for. You don't have to cancel the game or use the windows button and wait for it all to load etc. Also you can watch movies or music videos while waiting for the computer to take it's turns. Or even read the news of course, or perhaps talk about the latest gossip on Shires stalker on this forum!?

    Rome: Total War

    (I don't get this to work myself because I get a steam error, but this has nothing to do with windowed mode, it has to do with not being able to create shortcuts, perhaps you guys using Steam also got it).

    Go to your RTW folder, there create a shortcut of the RomeTW.exe file.
    Right click the RomeTW.exe - shortcut, then click properties.
    Go to "shortcut", there you can see a target for the shortcut, which for me is;
    "C:\Program Files\Steam\steamapps\common\rome total war gold\RomeTW.exe"
    Now, write "-window" behind it, without the quotes. So it should look like this;



    Click "Ok" and don't forget to put a space between the original link and the -window.
    After that you should be able to play in windowed mode when your using the shortcut.

    (If -window doesn't work, try -ne or -w instead!)


    Medieval 2: Total War

    This also works with M2TW Kingdoms.

    This game I got with a box, not Steam (yay).

    Go to your Medieval 2: Total War folder. There you will find a file called medieval2.preference. Open the file with notebook or wordpad or anything similar. Go to the end of the file, the section there is "[video]", and furthest down it usually says "widescreen = 0". Below that write "windowed = true"

    Then it should look like this:



    After you have done that save it. Then use the medieval2.exe to start the game!

    Sometimes the file medieval2.preference resets itself to it's original, so if you haven't got a clue why the game doesn't go windowed mode, then redo this. It should only take some seconds.

    If you have a problem with saving the file then you can first copy the original medieval2.preference that you got in the M2TW folder to a safe place, like the "music" folder.
    Then you do the above "windowed = true" change, and save it to let's say the "pictures" folder instead of the M2TW folder. After that delete the medieval2.preference in the M2TW folder. Then you can copy the "windowed = true" medieval2.preference that you got in the "pictures" folder to the M2TW folder, and you should be all good to go!

    (An old post by Gluteus Maximus helped on this one.)


    Empire: Total War

    This is the most simple one. Start the game up as usual, go to options > graphics, then click the box where it says "windowed".

    I haven't got Napoleon: Total War, but my guess is that it is the same as in Empire: Total War.
    Last edited by Leckan; 07-25-2010 at 06:33 AM.

  2. #2
    Junior Member Private
    Join Date
    May 2012
    Posts
    7

    Default

    this is great but my games are starting with a black screen which could be fixed if i had the window option to start with for Napoleon and medieval 2

    Empire works and if you have played the before and it goes black, make all hidden files visible, go to your main program file that has everything from music file to download ect and your see one now called appdata go to roaming The Creative Assembly empire and delete the script file.

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts