Total War Forums

+ Reply to Thread
Results 1 to 5 of 5

Thread: Empire on Windows 8

  1. #1
    Junior Member Private
    Join Date
    Aug 2013
    Posts
    1

    Default Empire on Windows 8

    I'm upgrading my computer soon and the best I've found for a decent price uses windows 8. All the info I found on empire's system requirements only said it works on windows 7 at the latest.
    Is it able to run on windows 8?

  2. #2
    Moderator Captain DarK's Avatar
    Join Date
    May 2010
    Location
    NSW, Australia
    Posts
    560

    Default

    I don't see why not, both Windows 7 and 8 are both essentially architecturally identical. And it's had long enough for drivers to balance themselves out in to a stable manner.

    You might want to make sure the CPU and GPU in the system is going to be enough for your needs now and in the future though.

  3. #3
    Senior Member Sergeant-Major frigginjoe's Avatar
    Join Date
    Sep 2013
    Posts
    332

    Default

    Runs quite well on my second PC using Windows 8.
    i5 2500K @ 4.5ghz | nVidia GTX 770 OC 4gb
    FX-8320 @ 3.5ghz | Radeon HD 7870 2gb
    http://www.pocketpiglets.com/private/custominf.html (in case it helps)

  4. #4
    Junior Member Private
    Join Date
    Oct 2013
    Posts
    1

    Default Windows 8.1

    I upgraded to Windows 8.1 and should of course have known better. Graphics in TWE got all distorted, pinkish in colour and like watching a 3d-movie without 3d-glasses. Now I can't play.

    Graphis card is GeForce GTX650 Ti Boost.

    How shall I deal with this?

    Was adviced to upgrade with GeForce 331.40 beta driver, but hesitates. Suggestion anyone? All help appreciated.

    Rgds
    H.

  5. #5
    Junior Member Private
    Join Date
    Dec 2013
    Posts
    1

    Default

    Henning61, I had the same issue with the stereo being on by default. I did this: Go to the Nvidia Control panel and look for the stereoscopic 3D tab. Just disable the stereo which has been set to be on by default, I guess as part of the 8.1 upgrade? Try that and see if it remedies the situation.

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts