Total War Forums

+ Reply to Thread
Results 1 to 6 of 6

Thread: Boosting the game for low graphic cards (geforce products only)

  1. #1
    Member Private ringwraiths's Avatar
    Join Date
    Mar 2013
    Location
    Belgium
    Posts
    37

    Post Boosting the game for low graphic cards (geforce products only)

    Hey guys, a tip to improve your graphic card preformance (if you have a NVIDIA or other Geforce product).

    I have a NVIDIA Geforce 9600M GT (wich is a low graphic card but within the min. specs for Rome II).

    After setting my 3D options in the NVIDIA configurations menu to "preformance" instaid of "quality" i could play Rome II but with serious low frames per second.

    Now i installed the program "Geforce experience" downloaded the latest update possible for my graphics card and from this point on i can play the game smooth on low settings

    I recommend all NVIDIA users to do the same.

  2. #2
    Senior Member Corporal
    Join Date
    Sep 2013
    Posts
    122

    Default

    I have the 9800M GTS and have the latest beta and drivers installed. I actually got it to a point where I got 30 fps with graphics worse than Rome 1...but as soon as I go to play the actual game it is back to the stuttering.

  3. #3
    Junior Member Private uk500's Avatar
    Join Date
    Aug 2010
    Posts
    15

    Default

    I have a NVIDIA Geforce 9500 GT 1GB, I know its a bad card, however I was able to run shogun 2 on medium with decent frame rate.
    That was with mods too. I was also able to play a 40v40 battle without lag. The thing that really helped me, was turning of shadows.
    Really boosted my fps. I was expecting to be able to run at least low on Rome 2. However I get around 3-10 fps in battles.

  4. #4
    Senior Member Corporal
    Join Date
    Aug 2012
    Posts
    121

    Default

    Quote Originally Posted by ringwraiths View Post
    Hey guys, a tip to improve your graphic card preformance (if you have a NVIDIA or other Geforce product).

    I have a NVIDIA Geforce 9600M GT (wich is a low graphic card but within the min. specs for Rome II).

    After setting my 3D options in the NVIDIA configurations menu to "preformance" instaid of "quality" i could play Rome II but with serious low frames per second.

    Now i installed the program "Geforce experience" downloaded the latest update possible for my graphics card and from this point on i can play the game smooth on low settings

    I recommend all NVIDIA users to do the same.
    I have a 9600 GT, and the geforce experience wont even work.

  5. #5
    Member Private
    Join Date
    Sep 2013
    Posts
    36

    Default

    9800GT user here. try to turn off threaded optimization in nvidia control panel. improves performance.

  6. #6
    Senior Member Corporal
    Join Date
    Sep 2013
    Posts
    122

    Default

    Quote Originally Posted by GokhanOzcaner View Post
    9800GT user here. try to turn off threaded optimization in nvidia control panel. improves performance.
    I will have to give this a shot when I get home.

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts