Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Loading screen problems for Rome 2

AtholosAtholos Junior MemberPosts: 1Registered Users
Me and a friend of mine have encountered the same problem, when the game starts after the launcher it will no load past the first screen with the Sega and CA logos on it. after this it will crash when I try and alt tab or minimize it. how can I fix this?

Thanks!!!
Post edited by Atholos on

Comments

  • HloericHloeric Member Posts: 42Registered Users
    edited October 2013
    If you have clicked start the game and then it freezes and fails to respond when at the rome 2 crimson screen then try this easy fix

    - open your start menu (bottom left of your screen)
    - in the search box type %appdata% a file box should appear titled "Roaming"
    - Click that file
    - Look for a file titled "The Creative Assembly"
    - Click that file
    - A file titled "Rome2" should appear
    - Right Click on that file and click delete
    - (Additional) Once I deleted this entire file it still froze I had to delete the "Rome2" file and reboot my laptop a hey presto now it works hope this helps people

    so in summary

    Start Menu > Start menu search bar (Type %appdata%) > Roaming > The Creative Assembly > right click Rome2 and delete

    WARNING you will lose your saved games but the game will work again, unless some nice person adds to this thread how to keep your saved games Enjoy
  • istheconqueroristheconqueror Junior Member Posts: 3Registered Users
    edited October 2013
    If you rename the folder instead of deleting it then transfer the savegame files to the new folder it creates when launching it again you can save your saved games but dose anyone know another solution besides this. I've been trying since launch to play but i still have never been able to. I have the collectors edition too :/
  • henri5henri5 Senior Member Posts: 156Registered Users
    edited October 2013
    If you had mods installed, Patch 4 might be incompatible with them, and you have to remove the mod(s). When I removed the mod, I could get to the saved games, but the saved games would not load. I could start a new campaign though. Bottom line: if you had mods installed, you might have to remove the mods but not be able to play any saved games.
  • Spartan1989Spartan1989 Junior Member Posts: 1Registered Users
    edited October 2013
    I had the same problem with you and I tried the sugested solution (as mentioned from Hloeric above) with no results. The problem was caused by the moding packages cause the are not compatible with the last version of Rome II. If you have instaled moding packages try deleting them first before unistalling the game and see if your problem is solved.

    What I did to run it properly was 1. to erase the local content from steam, 2. then I erased both Rome II total war files from C:\Program Files (x86)\Steam\SteamApps\common\Total War Rome II and from C:\Users\Demetrio\AppData\Roaming\The Creative Assembly\Rome2
    3. then I reinstalled the game 4. I let it download all the 3 patches, and it's working perfectly.

    Greetings from Greece!!
Sign In or Register to comment.