Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Screen Flicker in full screen

MorighanMorighan Junior MemberPosts: 1Registered Users
I've just installed the game and I'm having some significant graphic issues. When I play the game in fullscreen, the screen is flickering constantly, while its fine when played in windowed mode. I've messed around with the ingame settings. It works perfectly with all maxed settings in windowed but still flickers with lowest in fullscreen.

Graphics Card: ATI Radeon HD 5950
Processor: Intel i& Quad Core overclock to 4ghz.

Any suggestions would be greatly appreciated.
Post edited by Morighan on

Comments

  • tk6918tk6918 Junior Member Posts: 1Registered Users
    edited March 2011
    I have the same issue.

    Graphics Card: Ati Radeon HD 5970
    Processor: AMD X6 1100T

    I think I've noticed having the issue after installing Crysis 2...
  • the_ecdthe_ecd Senior Member Posts: 153Registered Users
    edited March 2011
  • LawliethLawlieth Junior Member Posts: 3Registered Users
    edited April 2011
    I had the same problem, after I've installed Crysis2 i have flickering in almost all games ... what should I do?

    Please Help!
  • the_ecdthe_ecd Senior Member Posts: 153Registered Users
    edited April 2011
    Maybe the latest (11.3) ATI driver will help. Or even the 11.4 preview driver is worth a shot as well. Jus tremeber to uninstall the older ones first and run Driver Sweeper.
  • LawliethLawlieth Junior Member Posts: 3Registered Users
    edited April 2011
    the_ecd wrote: »
    Maybe the latest (11.3) ATI driver will help. Or even the 11.4 preview driver is worth a shot as well. Jus tremeber to uninstall the older ones first and run Driver Sweeper.

    Yeah,i have installated the latest catalyst(11.3) + Apllication Profile 11.3cap1 and disinstalled the old driver(11.4 preview) with driver sweeper but i have flickering,What can I do? :(
  • NoobertNoobert Member Posts: 49Registered Users
    edited April 2011
    I have around the same as you guys, and I'm having the same problem except my screen flickers and then Alt + Tabs forcing me to reload the game in the midst of a battle.

    It causes massive lag for the player I am facing, and makes me angry because of how **** it is. :/
  • LawliethLawlieth Junior Member Posts: 3Registered Users
    edited April 2011
    Any solution ?
  • helldrivershelldrivers Junior Member Posts: 2Registered Users
    edited April 2011
    This problem is really common in Crysis 2 (see the forums over there). This has to do (or it does in Crysis 2) with Crossfire/SLI. Disabling CF/SLI should make the flicker go away. I haven't tried it, since that method in my mind is no solution, but it should work. Playing in windowed mode disables CF/SLI automatically, why that seems to work to.

    Again, I haven't tried fixing this in Shogun 2, but there are several work-arounds for Crysis that might be worth trying. Using RadeonPro to force a different CF profile worked for me (I choose the suggested Bioshock profile). Give that a shot.
  • ninjastealthninjastealth Senior Member Posts: 189Registered Users
    edited April 2011
    Morighan wrote: »
    I've just installed the game and I'm having some significant graphic issues. When I play the game in fullscreen, the screen is flickering constantly, while its fine when played in windowed mode. I've messed around with the ingame settings. It works perfectly with all maxed settings in windowed but still flickers with lowest in fullscreen.

    I had this happen to mean just once, and all I did was minimize the screen then click the game again then it refreshed it. If it is doing it alot then the other posts on here have the idea what is causing it.
Sign In or Register to comment.