Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Steam problems. Please help!

zoomzoomerszoomzoomers Junior MemberPosts: 4Registered Users
Hey guys,

I just downloaded Shogun 2 last night and when I went to install it I had problems. Let me explain. I have a Asus laptop (model G73JH-RBBX05) which has always had problems with Steam. If I install Steam the laptop immediately locks up and crashes. I've had this problem since I got the computer, but haven't found a resolution. So, I've basically stayed away from games that need to be played with Steam. Guess what? Shogun 2 automatically loads Steam on install.

So... my question is 2 folds. 1. is there a way to install Shogun 2 without installing Steam? 2. Does anyone out there know why or know of a solution to the problem I'm having?

If you post up advice or solutions, please be very specific and detailed. I'm not computer whiz. Thanks for reading and thanks in advance for your help.

z
Post edited by zoomzoomers on

Comments

  • SnoopyTRBSnoopyTRB Senior Member Posts: 864Registered Users
    edited March 2011
    1: No there is no way, Shogun 2 requires steam

    2: Not much help as to why, there are dozens of reasons it may be happening, I recommend opening a ticket with steam support, they will be more helpful in giving you detailed instructions on how to resolves issues.

    Steam Support Page
  • mmurray821mmurray821 Moderator Posts: 5,060Moderators
    edited March 2011
    Steam support is your best bet.

    Moved to S2TW support on the hope others have had a similar issue.

    Your specs for the laptop rock, so it isn't a performance issue. Tried uninstalling, rebooting and reinstalling Steam?
    Total War Forum: Terms and Conditions
    I've never seen the Icarus story as a lesson on the limitations of humans. I see it as a lesson about the limitations of wax as an adhesive.
  • zoomzoomerszoomzoomers Junior Member Posts: 4Registered Users
    edited March 2011
    Thanks for all your help guys. I will try steam support.

    Here's some more info. When I'm installing steam I get a box that states: running steam in compatibility mode is not recommended. Please remove any windows compatibility settings for all users under file properties for steam.exe and restart steam. Press "cancel" to permanently ignore this warning and continue.

    BTW, I'm running windows 7 64bit. Again, thanks. It's glad to know there are helpful people out there.

    z
  • zoomzoomerszoomzoomers Junior Member Posts: 4Registered Users
    edited March 2011
    I've just emailed Steam support. So I'm really hoping that I can find a resolution to this problem. I haven't been able to enjoy gaming for awhile now and now that I bought Shogun 2 I MUST get this problem solved.
Sign In or Register to comment.