Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

Impossible to rescind military access

AnolyticAnolytic Junior MemberRegistered Users Posts: 22
edited February 2015 in Total War Eras Support
I shared military access with Pontus (Imperator Augustus Campaign as Octavian). When some time had passed I didn't need military access anymore and they started to become enemies with my allies. I made a deal with another faction that I would end my military access pact with Pontus in return for them shedding a client state (some money changed hands as well). A few turns later however I checked the diplomacy-panel for Pontus and military access was still listed in the treaties column. And the x beside it to end the pact is grayed out. If I hover over it the tooltip says "Can't cancel treaty". If I enter negotiations with another faction and offer to break military access pacts, Pontus isn't listed as an option.
Now, several turns later, Pontus has lost all their territories and my trade agreement with them disappeared (without me getting a notification at the beginning of the turn btw), but I still am bound by my military access treaty.

This has to be a bug, no?

And btw, when I made the deal with another faction to break military access with Pontus. I did get the broken treaties penalty to my relations with them. Their territory was also grayed out. I didn't actually try to trespass before they were driven out of their territories though.
Post edited by Anolytic on

Comments

  • AnolyticAnolytic Junior Member Registered Users Posts: 22
    edited October 2014
    When I now try to declare war on Pontus to destroy their last fleet and annihilate them I get a severe penalty to my reliability. Which I'm not too happy about as I've played 200 turns without going below dependable.
  • SlaistsSlaists Senior Member Registered Users Posts: 2,902
    edited October 2014
    This happens if you both are at war with a common enemy when you try to cancel the access. When that common war ends, you are allowed to cancel the access.
  • AnolyticAnolytic Junior Member Registered Users Posts: 22
    edited November 2014
    It's a long long time since we were at war with the same factions. Before I even tried to rescind military access. They're allied with my enemy, and enemies with my friends and have been so for a long time.
  • Paolo CAPaolo CA The Creative Assembly CA's nuragheRegistered Users, Moderators, CA Staff Mods, CA Staff Posts: 2,515
    edited November 2014
    Hi, thanks for reporting this.

    Have you got a savegame from where I can reproduce the issue and you'd be able to upload it please?

    Also, are you using any mod? If so, please have a look at this FAQ here and see if your issue is still happening after uninstalling all your mods.

    Thanks for your help.

    PaoloCA
    PLEASE READ THIS THREAD BEFORE POSTING YOUR ISSUE ON THE FORUMS.

    For any issues you may have, there might already exist a solution/workaround.

    Forum Terms & Conditions

    Formal disclaimer: any views or opinions expressed here are those of the poster and do not necessarily represent the views or opinions of The Creative Assembly or SEGA.
  • AnolyticAnolytic Junior Member Registered Users Posts: 22
    edited November 2014
    It's some time since I destroyed Pontus now, but I might be able to find a savegame with the issue. How do I upload it?

    Also I use no mods, I verify game cache from frequently, and it's not that long since I reinstalled the game.
  • Megaman112Megaman112 Junior Member Registered Users Posts: 28
    edited February 2015
    I've come to the conclusion that this is a bug: I replicated this bug in Caesar in Gaul campaign, where i need to go to war with my first friends and to gain something out of it: I asked bellovaci, their enemy, to break every pact for some gold, but after that the "military access - can't cancel" appeared.
    After that I tried to march with an army into Atrebates' territory, and i got the warning of trespassing, so we don't actually have military access (or maybe they have it on my territory, and I don't on theirs)

    2015-02-24_00002.jpg2015-02-24_00004.jpg

    p.s. tried to attach a savegame file but an error appeared:

    503 [IOErrorEvent type= "ioError" bubbles=false cancelable=false eventPhase=2 text= "Error #2038"]
  • RaymanYRaymanY Registered Users Posts: 5
    Have the same problem
  • Sukabliat12Sukabliat12 Registered Users Posts: 24
    i have same problem.

    wh2
    i am avelorn
    have some tomb kings M.Access and cant revoke
This discussion has been closed.