Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.


ATTILA vs Mac Pro: list of issues.

PigrekoPigreko Registered Users Posts: 4
edited June 2015 in Mac & Linux Support
--- The first encountered is the most absurd: It is not possible to play full screen at higher resolution than 1600x900. And no matter how I change the settings, the game is going to stutter... a lot... for any kind of action i make. I've done the first prologue battle and the MINIMUM possible setting at it was very far from being fluid.
Playing in window mode is better, at least I can go up to 1080p, yet it still performs poorly unless I set half of the parameters to the minimum and uncheck AA SSAO and company. At this point the game still drops fps during medium to large battles. Plus the game reads only 4000 of the 6000 mb of video ram I have per video card )and I have 2 of them)

--- The second issue was with the save files. Some times they corrupt so the game crashes after the save and cannot even launch properly anymore. It is resolved via the removal of such save files. Yet I can only play with quick saves now (immune to such behaviour) cause normal save files already failed me three times.

--- The third and most recent issue is the freeze + reboot phenomenon. It happens out of nowhere, during a battle or while looking at the world map. It is absurdly strange, and does not look to be connected to a peculiar temperatures or incredible processor load. UPDATE: the system diagnostic actually reports an increase in load for the CPU just before the crash. So the problem is probably there... somehow.

--- Fourth anomalous issue is somewhat linked to the first, yet it is pretty strange as itself: the game very much alter its performances over time of the whole system, especially if you mess around with the options. For instance I removed the deep of field during a battle, and suddenly all the particles disappeared. No arrow trails, no fire, no rain. I had that setting to the maximum quality so I really did not understand what was happening. Reverting the setting back did nothing.
Furthermore I had to kill the game while writing this, since it was causing massive lag spikes to the whole computer, just because I tried few resolutions, went fullscreen again to see in details how settings affected the game, then reverted to windowed a few minutes ago.

My mac is a Mac Pro (late 2013)
3 GHz 8-Core Intel Xeon E5
32 GB 1866 MHz DDR3 ECC
2 x AMD FirePro D700 6144 MB
Post edited by Pigreko on


  • ignominious1signominious1s Registered Users Posts: 3
    edited June 2015
    Hi there,

    I have a new 2013 Mac Pro as well, albeit with inferior specs, and I am experiencing essentially all the same issues you are.

    The worst of which is the freeze and reboot which is occurring constantly now after having logged a few hours of decent gameplay.
    I tried the deleting of save files. It doesn't fix the issue.

    This is driving me crazy as I purchased the game and all the DLC but I'm not getting to enjoy it at all! And my computer has the specs to enjoy this game with generally high graphics settings!

    Thank You anyone for you Help!
  • okta85okta85 Registered Users Posts: 22
    edited June 2015
    I try to play with a pro 2015. Simply the game crash everytime a the end of the loading of a campaign. I haven't problem to play single battle but I can't open the campaign map. Video setting are setting to the minimum. Instead I play good, only with minimum detail, on the Pro 2012 of my girlfriend.
  • ignominious1signominious1s Registered Users Posts: 3
    edited June 2015
    I have the same issue. Battles run great on maximum graphics settings all around, but the campaign map causes my Mac to freeze and reboot.

    And I've been emailing tech support for over a week now with very poor results.

    I'm beyond dissapointed with this situation.
Sign In or Register to comment.