Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

Cant Join Multiplayer Campaigns?

Spartacus VXSpartacus VX Junior MemberKentRegistered Users Posts: 3
edited March 2015 in Multiplayer
Hi there got Total War Attila on launch, had every total war game ever and never had any problems like this before so this one has really stumped me.

I go onto the multiplayer campaign list and every game on there is in red writing, i hover over to check out why and it says, "Can not join game due to incompatible versions" I have then tried hosting and inviting friends and no matter what I do it says incompatible versions.

I have tried the following:

Verifying Game Cache
Updating the Game
I have opened my ports and increased my NAT type to open

Can anyone help :)?
We fight for freedom!
Post edited by Spartacus VX on

Comments

Sign In or Register to comment.