Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

How to roll back to previous patches

Matthias CAMatthias CA AdministratorUKPosts: 2,596Registered Users
edited February 2016 in Support Forum
Hi everyone,

We’re pleased to announce that we are trying out a new process to help you enjoy our games as much as possible. Other studios have set up similare processes and we hope you will like this as much as we do!

Since Total War: Attila’s new update (Patch 3, which is released today alongside “The Last Roman Campaign” DLC) we will be keeping the previous patch in the Beta tabs accessible by everyone to ensure you can “roll-back” to the previous patch if, for whatever reasons you would prefer staying on the previous patch. [DISCLAIMER: This is for Total War: Attila only.]

WARNING: Saved games made on the latest patch will most certainly crash on the previous patch.

How to access the previous patch:
· Log into Steam, and go to the games library.
· Right-click “Total War: ATTILA”, select “Properties”.
· When the “Total War: ATTILA – Properties” window opens, go to the “BETAS” tab.
· In the “Select the beta you would like to opt into:” drop down list, select “patch_2.1”, and click the “close” button.
· “Total War: ATTILA” should update to the previous version.


If unsure or if you have any questions please do not hesitate to comment below.

Thank you for your support and understanding,

Matthias



PS. As of today the previous patch was patch 2.1 (Blood and Burning Hotfix)
PLEASE READ THIS THREAD BEFORE POSTING YOUR ISSUE ON THE SUPPORT FORUMS.

Need to contact us?

Forum Terms & Conditions

Formal disclaimer: any views or opinions expressed here are those of the poster and do not necessarily represent the views or opinions of The Creative Assembly or SEGA.
Post edited by CraigCA on

Comments

  • Sulieman the MagnficentSulieman the Magnficent Senior Member Posts: 1,851Registered Users
    edited June 2015
    Now that is an epic title! Haha, can you guys provide some support for us in the Assembly kit forum? We can't convert our files!
    Dwarf Battle cry: " For the High King and the glory of the dwarfs "
    Team Dwarves
    "
  • KlunzKlunz Senior Member Posts: 1,436Registered Users
    edited June 2015
    This is a great feature. A patch can often break mods you're using, so this is awesome if you prefer your mods over the new patch!
    [PORTABLE-ID]crazysteve[/PORTABLE-ID]
  • RiekopoRiekopo Senior Member Posts: 2,254Registered Users
    edited June 2015
    Thank you for doing this. Now start doing patch betas for the ones you're working on.
  • ThonyRiotThonyRiot Junior Member Posts: 2Registered Users
    edited June 2015
    Phew, this is a big relief. Thank you for respecting my awesomely modded campaign.
  • RiekopoRiekopo Senior Member Posts: 2,254Registered Users
    edited July 2015
    Also, it would be better if you kept more than one previous patch. Keep as many as possible as options.
  • HowFarWouldYouGoHowFarWouldYouGo Senior Member Posts: 862Registered Users
    edited July 2015
    Riekopo wrote: »
    Also, it would be better if you kept more than one previous patch. Keep as many as possible as options.
    They did since the hotfix there are now 2 betas available, I hope they continue from now on. The one year of crying for this feature since Rome 2 has paid off.
    Thank you CA for listening to the community.
  • FaridusFaridus Junior Member Posts: 3Registered Users
    edited October 2015
    I have just reverted to Patch 2.1 and I seem to have some issues with the Assembly kit.
    TWEAK is working I think, but BOB crashes on startup!

    On the other hand, does anyone know which table I need to use to change unit in game name?
  • PhilipFPhilipF Junior Member Posts: 18Registered Users
    edited October 2015
    Might this actually help solve launcher crash issues? I came back to Attila a few days ago after last playing about a month ago and I can't get it to start...It keeps crashing on the loading screen...Everything was working fine last month, even though I'm playing on quite a low spec laptop, and none of the other solutions proposed elsewhere seem to work...However, I notice the last patch was on October 1st, so could rolling it back to the last one restore my ability to play?
  • CagatayKhanCagatayKhan Senior Member Posts: 814Registered Users
    edited October 2015
    Hi everyone,

    We’re pleased to announce that we are trying out a new process to help you enjoy our games as much as possible. Other studios have set up similare processes and we hope you will like this as much as we do!

    Since Total War: Attila’s new update (Patch 3, which is released today alongside “The Last Roman Campaign” DLC) we will be keeping the previous patch in the Beta tabs accessible by everyone to ensure you can “roll-back” to the previous patch if, for whatever reasons you would prefer staying on the previous patch. [DISCLAIMER: This is for Total War: Attila only.]

    WARNING: Saved games made on the latest patch will most certainly crash on the previous patch.
    WARNING2: You will only be able to play multiplayer with players on the same version of the game / patch as yourself. So to play multiplayer it is advised to keep on the latest patch released.


    WARNING3: The beta/roll-back patch (patch 2.1 at the moment) will be replaced by the following patch (patch 3 at the moment) once a new patch comes out. When this happens you will automatically be kicked out of the Beta/roll-back patch you had subscribed to (patch 2.1) and will be downloading our latest patch (which could be patch 3.1 or patch 4).


    How to access the previous patch:
    · Log into Steam, and go to the games library.
    · Right-click “Total War: ATTILA”, select “Properties”.
    · When the “Total War: ATTILA – Properties” window opens, go to the “BETAS” tab.
    · In the “Select the beta you would like to opt into:” drop down list, select “patch_2.1”, and click the “close” button.
    · “Total War: ATTILA” should update to the previous version.


    If unsure or if you have any questions please do not hesitate to comment below.

    Thank you for your support and understanding,

    Matthias



    PS. As of today the previous patch was patch 2.1 (Blood and Burning Hotfix)
    Rome 2 patch 14 plss
  • VespasianvsVespasianvs Posts: 6Registered Users
    Which version is the one directly before Charlemagne came out? After its release, it bugged the Roman dialogue in the main game, and I'd like to get it back.

    Thanks for adding this feature!
Sign In or Register to comment.