Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

ERROR MESSAGE "Please login with administrator privileges and try again"

mdoodle22mdoodle22 Junior MemberRegistered Users Posts: 1
edited October 2015 in Rome: Total War
Everytime I try to run my hard copy of rome total war it says "Please login with administrator privileges and try again" even though I am the administrator and I even tried running it as administrator and it still doesn't work. I have windows 8 and even moved the files to "program files" instead of where they were created in "program files x86" also it is the gold edition that has 3 disks and another disk for "ROME total war Barbarian Invasion", any help would be greatly appreciated. Also when I run the RomeTW.exe in the dvd RW Drive ("E:") it says "the program can't start because MSS32.DLL is missing from your computer. Try reinstalling the program to fix this problem. Which i already did reinstall it.
Sign In or Register to comment.