Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Total War: ATTILA - Assembly Kit Updates and Fixes (13/01/16)

Darren_CADarren_CA Creative AssemblyPosts: 295Registered Users
edited January 2016 in Assembly Kit
Hey everyone, so the tools team are looking into some of the issues you've been experiencing and are looking for any feedback you can give with regards to how it's all working.

The Assembly Kit has just updated today (13/01/16) and received the following fixes:

- Fixed Crash to Desktop upon opening Terry
- Terry currently only supports saving of maps as main_attila_map.terry. Saving as any other file name will cause other dependencies to fail. We recommend saving a backup of the main map before beginning to edit your map.

As well as that, I've gathered some of your feedback and the team are looking into the following:

• Blend maps in Ted only show the default terrain texture (grass 0) regardless of any new overlays.
• Building files are missing max script(or dll file? plugin?) for proper conversion in BOB:
• Wall bug not allowing troops on or off walls even when deployed
• Height Map saving bug.
• Siege AI crashes. Explanation of how Siege AI Graph is setup.
• Assembly Kit missing files / Error when opening building example.

Two bugs we recieved that aren't going to be fixed are:
• Show Skeleton in Tweak->Variation Editor doesn't work.
• Animations don't appear if you load definition file in.
According to Warman2222 "if you load it via "load uniform" and it uses a vanilla animation table set, it does work"

The reason for that is that the functionality was never added, the buttons were placeholder for being used eventually but the team never needed them. The buttons may be removed eventually.

Post edited by Darren_CA on

Comments

  • mrtspencemrtspence Junior Member Posts: 28Registered Users
    Keep the mod tool updates coming! This is really encouraging to see as a vibrant modding community keeps games alive for years. I recently got several friends to purchase Medieval II because of the superb Total War: Third Age Lord of the Rings mod. I will happily buy Attila if the LotR Rise of Mordor mod gets off the ground and more updates to the toolset will help that process.
  • CauselessCauseless Senior Member Posts: 364Registered Users
    Terry fails to load raw_data/battles/main_attila_map, giving many "failed to compile" errors and "Multiple shaders created with the same in-memory cache name. This will leak memory", along other errors.

    The file is never loaded, and eventually it just freezes up my computer.
  • Mr_JMr_J Senior Member Posts: 213Registered Users, Cakes!
    @warman "Thanks for the effort guys. Got a thing to report that needs fixing. In the naval folder I think there's a rules.bob file missing. As a result we can't really do too much in terms of new ships. So maybe add that when you can."
  • Doomon15Doomon15 Junior Member Posts: 44Registered Users, Cakes!
    edited January 2016
    Thank you Darren and your guys team for listening to our efforts I put together in the thread now we can finally hope to see action taken against these problems that have disturbed our many groups progresses with hopefully better functioning tools. Cant wait and hopefully most of the dilemmas I and many other listed can be fixed.

    "Burn the heretic,
    kill the mutant,
    Purge the unclean"

    -WH40k
  • warmanwarman Junior Member Posts: 82Registered Users, Cakes!
    Here's proof of the load uniform thing working:




    So maybe there's enough working to get more functionality here, instead of taking it away.
  • BenguizzBenguizz Posts: 1Registered Users
    Nice to see CA get this fix, but not sure to understand due to my bad english, but these bug still need to be fix?



    • Blend maps in Ted only show the default terrain texture (grass 0) regardless of any new overlays.
    • Building files are missing max script(or dll file? plugin?) for proper conversion in BOB:
    • Wall bug not allowing troops on or off walls even when deployed
    • Height Map saving bug.
    • Siege AI crashes. Explanation of how Siege AI Graph is setup.
    • Assembly Kit missing files / Error when opening building example.
  • Mr_JMr_J Senior Member Posts: 213Registered Users, Cakes!
    When press reload textures in Ted all textures turn black.
    proof:

  • Mr_JMr_J Senior Member Posts: 213Registered Users, Cakes!
    Custom buildings converted through BOB do not appear in TeD building tree selector
  • Darren_CADarren_CA Creative Assembly Posts: 295Registered Users
    Hey Mr.J for this one "Custom buildings converted through BOB do not appear in TeD building tree selector"

    Can you send us any files/projects you have that show this and we can debug it.
  • Mr_JMr_J Senior Member Posts: 213Registered Users, Cakes!
    It seems like there's problems with database tables. Bob generates 2 tables battlefield_buildings and models_buildings but building doesnt appear in ted with custom name. If I go to Tweak->Dave and find there unused vanilla building name in battlefield_buildings (for example, like 30_30_30) and rename my building files to 30_30_30 instead of new_fort_straight or any other building, new record '30_30_30' appears in ted Create->Buildings (in both dropdown list and building selector).
    But if the name of my custom building isnt vanilla it does not appear in TEd
  • Quintus_PetilliusQuintus_Petillius Senior Member Posts: 142Registered Users
    Regarding the texture issue. I do not know what "reload textures" is there for since it doesnt work but to show the textures scroll to the bottom of the screen and select the "mountain icon" by the "head icon"

    Default should be highlighted. Select another texture, for example med, and after it loads reselect default. After default loads reselect another texture and you will then be able to see the textures correctly.
    Steam ID: Quintus_Petillius_Cerialis
    Steam maps
  • Quintus_PetilliusQuintus_Petillius Senior Member Posts: 142Registered Users
    I received a crash while saving as battlefield with the bridge_stone_1 model. I checked with the BOB readme that writes out after the crash. It lists the bridge as an Error. Once deleting it and resaving the issue disappeared. Among other models that failed to save as battlefield I hope this is fixed.
    Steam ID: Quintus_Petillius_Cerialis
    Steam maps
  • Sulieman the MagnficentSulieman the Magnficent Senior Member Posts: 1,851Registered Users
    Also AI tends to rush out a lot in sieges.
    Dwarf Battle cry: " For the High King and the glory of the dwarfs "
    Team Dwarves
    "
  • SwordstormSwordstorm Posts: 1Registered Users
    Please fix issues with Ted! I would really like to make battlemaps!
Sign In or Register to comment.