Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

Rome 2 on Ultra with 60+ fps, but shogun 2 goes to the 30-40s?

HoolioHoolio Registered Users Posts: 1
Hi, all.

I bought shogun 2 a while back, and I am thoroughly enjoying it on Medium graphics, even if the fps dips to the 20-30 range during full stack battles, but then I decided to buy Rome 2, and to my surprise, it ran perfectly on Ultra graphics settings. I even tried a 40 v 40 battle, and it ran amazing, compared to shogun 2. Of course, the slight fps drop was there when zooming in to a blob of units slugging it out in melee, but it was nothing compared to shogun 2.

I've tried everything that was in the ***Before you post*** thread here:(https://forums.totalwar.com/discussion/9291/before-you-post-in-the-total-war-shogun-2-support-forum-please-read-first#latest), updated BIOS, verified game cache, and replaced the thermal paste on my heatsink, but to no avail. I think most of the relevant drivers are up to date too.

My specs are:
CPU: Intel i5 4460 @ 3.20 GHz
GPU: AMD Radeon R9 280X 3GB video memory
RAM: 8GB

I have a feeling that this may be the result of a combination of poor cpu optimisation, and a cpu bottleneck, but I just don't understand why I can run the more demanding Rome 2 completely fine, and have problems with Shogun 2! I'd like some opinions before I consider upgrading my cpu.

Thanks in advance for any advice.

I can't seem to post my dxdiag even when splitting it into quarters, so I've just attached it to my post.
Sign In or Register to comment.