Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

AoC: Crashing at AI separatist faction turn

Greetings,

I'm 34 turns into my AoC campaign as the Franks and having a blast. Unfortunately, after ending my turn the game stops responding at the "Gallacian Separatists'" icon.

I've gone back to previous saves to see if that would help, but the crash repeats itself without fail at about turn 33 or 34. I am submitting four crash dump files from my attempts to return to earlier savegames.

As for mods, I'm running several reskin packs that should have no bearing on the campaign. However, I am also running a Theme of Sicily unlocker. It cannot be disabled, or the save will not load. I'm not sure if the mod is causing this or not, however, I have seen many other users with similar issues regarding crashes at AI separatist faction turns, so I thought it would be worth a shot to post this info.

Thanks,
Captain Turtlefingers



Comments

  • Lexi_CALexi_CA Posts: 1,677Registered Users, Moderators, CA Staff Mods, CA Staff
    Hi,
    Thanks for the info I'll pass it along for you. As you pointed out it is already a known issue and we are currently looking into it. Thanks for taking the time to post :)
    Formal disclaimer: any views or opinions expressed here are those of the poster and do not necessarily represent the views or opinions of Creative Assembly or SEGA.
  • toaster09toaster09 Posts: 33Registered Users
    any update? I'm having the same issue, also can we get a list of the crashes as a separate sticky thread so we all know the ones devs are working on
  • Bylandt11Bylandt11 Senior Member Posts: 132Registered Users
    edited May 2016
    Lexi_CA said:

    Hi,
    Thanks for the info I'll pass it along for you. As you pointed out it is already a known issue and we are currently looking into it. Thanks for taking the time to post :)

    Apparentely, it's been more than 2 months you've been "looking into it", Lexi. Don't think we're not grateful. But I hope I'm not imposing in asking you to tell us the results of this very lengthy "looking into" this gamebreaking bug that is affecting so many people?

    Thank you for taking the time to post an answer.
  • CrotouCrotou Junior Member Posts: 28Registered Users
    Hi Bylandt,

    I encountered this bug two times now. Once in the Grand Campaign and once in the AoC campaign.

    I just tried something and it worked : I removed the fog of war using a mod proposed in the workshop. I ended the turn and no crash occured ! Then I disabled the mod. I don't know if it will work the next time I will have the very same problem but it worked this time.

    I hope it can help you and all the others. ;)
  • Bylandt11Bylandt11 Senior Member Posts: 132Registered Users
    Thank you for helping us out, Crotou. And I will try your solution.

    But we shouldn' t accept the fact that CA takes money from people for a defective expansion and doesn't have the courtesy to try and fix a bug that is at the same time completely game breaking and experienced by many. If it would appear to be as easily fixed as you suggest, their complete lack of helpfulness and silence are all the more disgraceful.
  • CrotouCrotou Junior Member Posts: 28Registered Users
  • SeamusLightSeamusLight Posts: 10Registered Users
    Crotou said:

    Hi Bylandt,
    I removed the fog of war using a mod proposed in the workshop. I ended the turn and no crash occured !

    I tried this as well, using the mod in the workshop. I finally got to see the units which ruined my game - three small armies of Frankish separatists (4-5 units each) attacking a minor faction's last settlement.

    I hit "end turn," and it crashed. I tried befriending them, and it crashed. I tried declaring war on them, and the game carried on for another half second before crashing.

    CA knows what the problem is. They just don't care. They're too busy carving up Warhammer for DLC. They've even stopped sending the community managers to give us insincere promises of "we're working on it." They're not working on it. They're hucksters who sell defective products and treat us like idiots. Screw this. I avoided Rome II because of this amateurish design, and now I see nothing has improved. I'm never buying a CA product again. No wonder SEGA lost the console war.
  • CrotouCrotou Junior Member Posts: 28Registered Users
    My other campaign (with the Picts) had the same problem. Roman Separatists attacking a minor's settlement with a little army. I edited my save file to give the city of the Separatists to the Sassanids and after that I was able to resume my campaign.

    It took me a week or two to fix this silly bug by my own... Thank you CA !
  • joproulx99joproulx99 Junior Member Posts: 440Registered Users
    My AoC Dane campaign is put to a stop due to this bug too. Never had this bug in over 500 hours in grand campaign though.
    "Fear me mortals, for I am the Anointed, the favored Son of Chaos, the Scourge of the World. The armies of the gods rally behind me, and it is by my will and by my sword that your weakling nations shall fall."

    ~ Archaon, Lord of the End Times
  • joproulx99joproulx99 Junior Member Posts: 440Registered Users
    Crotou said:
    Thx, I cant seem to make this tool work 100% :/

    the instructions in the 'read me' arent noob friendly enough for me.
    "Fear me mortals, for I am the Anointed, the favored Son of Chaos, the Scourge of the World. The armies of the gods rally behind me, and it is by my will and by my sword that your weakling nations shall fall."

    ~ Archaon, Lord of the End Times
  • CrotouCrotou Junior Member Posts: 28Registered Users
    After having extracted the SaveParser files. Open SaveParses.ini and copy-paste the right way to Attila.exe (something like C: Username/AppData/Steam/Roaming/CreativeAssembly/Attila/Attila.exe ).

    That's the first thing to do.

    All details here :
    http://www.twcenter.net/forums/showthread.php?637771-SaveParser-Editor-for-Total-War-savegames-v1-15-0-1
  • joproulx99joproulx99 Junior Member Posts: 440Registered Users
    Crotou said:

    After having extracted the SaveParser files. Open SaveParses.ini and copy-paste the right way to Attila.exe (something like C: Username/AppData/Steam/Roaming/CreativeAssembly/Attila/Attila.exe ).

    That's the first thing to do.

    All details here :
    http://www.twcenter.net/forums/showthread.php?637771-SaveParser-Editor-for-Total-War-savegames-v1-15-0-1

    Ok I managed to use it, I just hit the reduce army strength button for the frankish separatist and saved and it worked!

    Thx!!
    "Fear me mortals, for I am the Anointed, the favored Son of Chaos, the Scourge of the World. The armies of the gods rally behind me, and it is by my will and by my sword that your weakling nations shall fall."

    ~ Archaon, Lord of the End Times
  • gervbafdswgervbafdsw Posts: 3Registered Users
    edited April 18
    For their answers we are seeing CA has no interest but grab the customer's money and run, towards the next tittle hopping that once sold you get tired of it the soonest (since it no longer works) and spend again a big sum in a totally broken game that will also never be fixed... and that's their policy, believe it or not.
    Since they are not fixing the AI movements' turn crashes and deliberately answer evasions , the issue remains totally for the modders as usual.
Sign In or Register to comment.