Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

ClosedIf you're having a Crash/Black Screen on Startup Read here

GrudgeNLGrudgeNL Senior MemberPosts: 7,148Registered Users
edited May 2016 in Crashes
DX 11 Hardware Support

Folks, unfortunately, some of the problems being reported are due to out of date cards that do not support at least DX 11. Note this is a HARDWARE requirement, as newer drivers may have DX11 but the hardware on the card won't support it unless it is indicated that it has such support on the card.

If you have an older card make sure you have checked in your DXdiag which CARD you have, and then check with the manufacturer's site that it supports DX 11 first, to save yourself some time before looking at some of these other solutions.

Note that embedded chips such as Intel HD family chips do not need to be as old to not have DX 11 support, so you need to look very specifically at the exact chip and processor you have to match what you have with a list such as this one:

http://www.notebookcheck.net/Mobile-Graphics-Cards-Benchmark-List.844.0.html
(type 'Intel' for example in the upper left corner boc to get only intel mobile chips).

As an example see where HD4000 chips DO support DX 11, but something labelled only 'HD Graphic Family' attached to a Sandybridge cpu does not. There are a number of other reasons a chip below the capability of an HD4000 may not work, or equivalently drag itself across the threshold, but not having DX 11 support is unfortunately a showstopper.
~AlJabberwock


System Requirements (Steam)

MINIMUM:
OS: Windows 7 64Bit
Processor: Intel Core 2 Duo 3.0Ghz
Memory: 3 GB RAM
Graphics: (DirectX 11) AMD Radeon HD 5770 1024MB / NVIDIA GTS 450 1024MB / Intel HD4000 @720p
DirectX: Version 11
Storage: 35 GB available space
Additional Notes: *PC Integrated graphics chipsets require 4 GB RAM, e.g. Intel HD series.


A hotfix has been released. Please read this and update the game.

https://forums.totalwar.com/discussion/174203/day-one-hotfix#latest


___________________________________________________________________________________
___________________________________________________________________________________



A number of people seems to be having issues when starting in game, resulting in a crash to desktop or an indefinite black screen. Here are some of the known fixes that may work for you.

Start Game in Offline Mode
Some people have claimed this worked for them. In Steam, go to Steam in the top left corner and press: Go Offline. Now start the game.

Wait more than 5 minutes
Some people have claimed they had to wait quite some time for the game to load, longer than most games.

Add the game manually to Firewall Exceptions
Sometimes the firewall exception window doesn't appear and the user will have to add the game manually. A combination of this fix and the above two may be needed in order to be effective.

Turn off Steam Overlay for Warhammer
Go to your library, open up the properties of Warhammer. In the General tab disable Steam Overlay. Sometimes Steam Overlay may cause a crash on launching the game.


Otherwise, make sure you've updated your graphics card drivers, restarted steam and your PC, as well as making sure you've verified the game cache integrity.


___________________________________________________________________________________
___________________________________________________________________________________
Shigawire said:

@GrudgeNL here are some more solutions that worked for some people, you could put them in your OP.

Language Localization

If you want the game in a different language than English, wait until it's fully downloaded before you change the language to your preference. This solved the launch crash issues for some people.

Visual C++ Redistributables

Cosmic said:

FIXED - I have fixed my issue. When I launch the game from steam a steam window will open saying that its launching, then it disappears and nothing happens.

I opened up my local files - C:\Program Files (x86)\Steam\steamapps\common\Total War WARHAMMER and then opened _CommonRedist and then opened vcredist. I then open 2010 and installed both the exe files vcredist_x64.exe and vcredist_x86.exe. I did the exact same with the 2013 folder; installed both exe files.

Now my game works.

I also found the 2015 ones and installed these.
https://www.microsoft.com/en-gb/download/details.aspx?id=48145

Windows Service Packs - make sure your Windows is updated (PC user's responsibility)

Go to Start -> Control Panel -> Windows Update
Check manually if you're missing any Service Packs or other updates.
I could provide a link for you, but it needs to be in your Windows' language.. so you will need to google for it yourself.

D3DCOMPILER fix (only recommended for advanced users)

Andy6001 said:

Ooooooh fixed it! See the following link and read to the bottom. Basically you have to delete the D3DCOMPILER _43.dll in both System32 ansd SysWOW64 folders (this means nothing to me) and then reinstall Direct X. I won't try to explain it, just read this forum....

https://forums.marvelheroes.com/discussion/6661/d3dcompiler-43-dll-is-either-not-designed-to-run-on-windows-or-it-contains-an-error

Enjoy!


Disable mods you've installed, or just remove them. Some people have installed mods that caused their game to crash. If you do have mods installed, remove them just to be sure.



Disabling Multi-GPU
Shigawire said:

Another suggestion if you can't launch the game, for those with multi-GPU setups:

Disable Crossfire or SLI

See if that solves it.



Windowed Mode A:
douriel1 said:

SO , finally got a workaround for anyone who needs to start in windowed:

Dont bother with steam command lines, they just dont work.

Instead go to your steam folder: Steam\steamapps\common\Total War WARHAMMER

there make a shortcut from your warhammer exe to desktop, there , right click on that, go to preferences and then to target.

add "-windowed" without quotations at the end, seperated by a space from the rest of the already written path

start via that exe from desktop.

This should fix the problem for everyone with out of bounds errors or similar ones



___________________________________________________________________________________
___________________________________________________________________________________



Developer and Moderator Comments



the fact that folder is empty might be a queue. The game should auto create the preferences script file on first launch. Could you go in to the %appdata%\The Creative Assembly folder and completely remove the Warhammer folder. Afterwards try to launch the game again.


Windowed Mode B:
Guy_CA said:

For those looking to try different resolutions who can't access the menu:

1) Find your preferences file

2) CTRL + F and search for x_res. Try replacing the x_res and y_res lines with the below:

x_res 1920; # x_res , Fixed window width #
y_res 1080; # y_res , Fixed window height #

Hi Guys,

We're looking into any issues that are popping up as quickly as we can.

Please make sure you;

-Update your drivers
-Turning off steam overlays has helped some.
-Try in offline mode.
- If you launch in windowed mode while online that may fix the issue.
-Verifying steam cache

=)

The work arrounds posted by GrudgeNL have been reported to work for some users.
So when you are facing issues launching the game then by all means try the mentioned work arrounds.

But please keep in mind that they are work arrounds and might not work in you situation. Also some issues might just be because of the enormous amount of people launching the game at the same time.

CA is aware of the current issues reported about not being able to launch the game.

Grudge's Mods
Total War: Karling - Coming soon...-ish
Grudge's Total War: Attila - Sassanid UI skin here on the Steam Workshop
Post edited by lordmaximus77 on
«13456711

Comments

«13456711

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file