Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

User Info RequiredKeyboard stops working in campaign

HaXXspettenHaXXspetten Posts: 1Registered Users
edited June 2016 in Campaign & Battle Bugs
Okay so basically my keyboard suddenly stopped functioning completely about 7 hours into my first campaign in TW: Warhammer. Not just the camera panning hotkeys but everything, both on the campaign map and on the battle map. I've tried reseting the hotkeys to default, reloading to an earlier save, numerous restarts and validated my Steam cache but nothing helps. Haven't reinstalled it yet but I guess that would be the next thing to try

But what's worse is that this isn't the first time I've seen this happen; the exact same thing happened to me in Rome 2 and it completely broke the game for me which was the main reason why I stopped playing it so early. I seriously couldn't believe such a game breaking bug could still be allowed to exist several years later but I guess I was wrong

I found some old threads for prior TW games where people used save file editors to resolve problems they had with the campaign map camera but I'm not sure that'd work here since it's about not just that but every hotkey. Sooo anyone know any fixes?


Build 1.0.0
Save file: http://www.filedropper.com/dwarfs10
Dxdiag: http://www.filedropper.com/dxdiag_1


Edit: Tried again a few hours later and for the moment it's suddenly working again. Can't say if it's just temporary or not as of yet though
Post edited by Lexi_CA on

Comments

  • Lexi_CALexi_CA Posts: 1,677Registered Users, Moderators, CA Staff Mods, CA Staff
    edited June 2016
    If you get trouble again please post a copy of your dxdiag attached to a comment. Sadly we can't get files from 3rd party download sites.

    Have you tried a different keyboard before? Does this only happen in game? If so in all games for just TW as far as you're aware?
    Formal disclaimer: any views or opinions expressed here are those of the poster and do not necessarily represent the views or opinions of Creative Assembly or SEGA.
  • MonkeyFoxMonkeyFox Posts: 3Registered Users
    Hi,

    I have the same issue playing the new Total War Rome 2: Rise of the Republic campaign

    I know its not the same game.

    My bluetooth keyboard suddenly becomes unresponsive ingame.
    After closing the game (with mouse) back in windows the bluetooth never disconnected the device. Keyboard is responsive in windows.

    I can start up the game again and play for less than an hour before it happens again - new restart. Its kinda frustating when in happens mid-battle.

    Only in rome 2 total war: rise of the republic (but i didnt play the other campaign since update - i did play them before though and there was not a problem)

    Yes i am sure my bluetooth keyboard has new batteries and sufficient connection (10cm from receiver).

    To me, its pretty obvious that somehow its triggered in total war 2 rome.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file