Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

Shogun Total War Gold Edition

klaw93klaw93 Registered Users Posts: 3
Hello everybody,

okay so i just bought this bundle pack of shogun, Rome/barbarian invasion ,Rome Alexander, medieval total war/vikings and i cannot get these games working i have windows 10 and im sure that has something to do with it. now bear with me im not the most tech savy person. the games install just fine so far the only ones i have tried are shogun and Rome but when i try to start them up i get a message saying "Please log in with administrator privileges and try again." i have tried running the game as an admin. google has not been my friend for this issue so i dont know if im just looking at the wrong pages or what anyhelp would be much appreciated i played these games growing up and would love to dive back into them thanks.

oh and also i dont know if this makes a difference but i did run rome and medieval off of steam just had issues so i just went ahead and bought the disks.

Specs: ( like i said work with me here lol dont know if this is the right info)
Intel (R) Core (TM) i7-5500u CPU @ 2.40GHz
Intel (R) HD Graphics 550
Installed memory (RAM): 8.00 GB
Operating System: 64-bit x64- based processor


THANKS!!! :'( :'( :'(
Sign In or Register to comment.