Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

In ProgressZombie dragon along with other mounts vanishing

HaggrasHaggras Registered Users Posts: 3
edited July 2016 in Campaign & Battle Bugs
Build: V 1.1.0 10732.901123 (modded) (It says modded although I have turned off all the mods, don’t know what that is all about)

Detailed description:
I was playing through a Vampire Counts legendary campaign and got to the point where Mannfred leveled to 25 while standing in Eastern Sylvania. I had a Barded Nightmare equiped while allocating a skill point to the Zombie Dragon mount. When I accepted the skill point choice Mannfred was dismounted on the campaign map and was on foot. I went to the character detail panel to look for the mounts, but all of them had vanished.
I used a loading screen mod previously which switched out the artwork of the loading screen when I started the campaign – it was turned off at the time I allocated the skill point – due to me playing with a friend the other day which didn’t have the same build. But since this is a problem for others aswell, the loading screen mod shouldn’t be the cause of the problem. It seems like Mannfred had 7 followers, because when I ”unequiped” a follower, a new one took its place (just as some other people said) and it got my other two mounts back – but still not the dragon. Some says that they had to go back to the point before they allocated the skill and ”unequip” followers before allocating the skill point. That way they were able to choose the dragon as a mount. Seems like there is the same problem with his armour.

Reproduction Steps:

None taken. Hence it is difficult to reproduce this step since Legendary difficulty doesn’t offer me possibilities to save the game. I tried to reload, but the save point was when I accepted the skill point allocation – and I don’t have the time (nor the energy) to reproduce a whole new legendary campaign with the Vampire Counts.

Screenshot:

--

Details of any solutions that have already been attempted:
Reloading to previous point (which didn’t work since it was past skill point allocation)
Restarting the game

Sincerely
Post edited by ca_guy on

Comments

  • ca_guyca_guy Registered Users, Moderators, CA Staff Mods, CA Staff Posts: 1,171
    Thank you for the detailed report, we have passed this along.

    - Guy
    Formal disclaimer: any views or opinions expressed here are those of the poster and do not necessarily represent the views or opinions of Creative Assembly or SEGA. | Lord name: guise |
  • cybernetcrashcybernetcrash Registered Users Posts: 1
    Same problem for me, although I haven't installed any mods, and playing on normal difficulty. After spending the skill point on Zombie Dragon, the option to choose a mount in the character window, is grayed out.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file