Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

In ProgressCoop Campaign Battle Desync

SnurteSnurte Registered Users Posts: 9
edited August 2016 in Multiplayer Bugs
Hi,

Me and my brother played 2 campaigns before the Bestmen DLC without any desync issues in the battles. I'm the only one with the DLC installed. I started hosting a campaign where he plays the Dwarfs and we got to around turn 40-50 before we encountered the first desync in a battle. Most battles up to that point had been auto-resolved.
We tried loading the auto-save multiple times, but the battle desynced at more or less the exact same time (around 5 minutes in to the battle). Finally we gave up and auto-resolved that fight as well only to run into the same desync issue in the very next fight we tried to play (me or him as spectator).
The client gets a message about the host having left the game. The host gets a desync error.

To rule out connection problems we started a multiplayer battle and was able to complete without any issues. After that we loaded one of our old saves from the previous campaign where I played Greenskins and he played Chaos. We had no problems in completing a large fight there either.

Our next step was to start a new Beastmen/Dwarf campaign, but this time with my brother as the host. This time the desync showed up after only 9 turns in a fight where the Greenskins attack my brothers main army that is garrisoned in Pillars of Grumni.

We tried deleting the battle_preferences folder.

Warhammer v1.2.0 Build 10911.907064
Post edited by Matthias CA on
«1

Comments

  • SnurteSnurte Registered Users Posts: 9
    Hosts files

    Mini dump was too big to attach and the save game is not allowed.
  • BillyRuffianBillyRuffian Moderator UKRegistered Users, Moderators, Knights Posts: 40,043
    You should be able to attach them if zipped/compressed.

    "He uses statistics as a drunken man uses lamp-posts - for support rather than illumination." (Andrew Lang)

    |Takeda| Yokota Takatoshi

    Forum Terms and Conditions: - https://forums.totalwar.com/discussion/172193/forum-terms-and-conditions#latest

    "We wunt be druv". iot6pc7dn8qs.png
  • SnurteSnurte Registered Users Posts: 9
    Figured out a way to upload the save files and realized the mini dump isn't relevant because it has an older date.
  • LoadingplswaitLoadingplswait Junior Member Registered Users Posts: 14
    Campaign desync, battle desync. We've seen it all since the Beastmen DLC.

    Can confirm that the last hotfix patch did not resolve any desync problems.
  • HellbenderHellbender Registered Users Posts: 32
    Registered here just so I can weigh in.

    My buddy and I keep getting desyncs during large battles since the Beastmen DLC release. I'll attach the logs in a next post.

    Could we get some confirmation from CA that they're looking into the battle desync issue? It was working fine before the patch, and this is starting to look like Rome II desync problems all over again.
  • HellbenderHellbender Registered Users Posts: 32
    edited August 2016
    Apparently I can't post the battle desync report, since we had a campaign desync since then, which overwrote the previous report. Thankfully the campaign desync was quickly sorted out. The truly gamebreaking issue remains the frequent battle desyncs.

    In mosts cases, the battle desyncs at around the 5-6 minute mark. I'm the host playing Orcs, my buddy is playing VC. We both have:
    • Beastmen DLC
    • Blood DLC
    • No mods
    Campaign was started before the release of Beastmen, and unit size is on Ultra.
  • Matthias CAMatthias CA Administrator UKRegistered Users Posts: 2,580
    Hi snurte,

    We are investigating your issue but it seems like a very illusive issue that might originate from any turn before it actually happens.

    Therefore if you could save each turn from the first one to the one before it desyncs (as you said it was on turn 9 last time it would help us a lot if you could recreate that kind of situation so you don't have to send us too manys aved games).

    Thanks,
    PLEASE READ THIS THREAD BEFORE POSTING YOUR ISSUE ON THE SUPPORT FORUMS.

    Need to contact us?

    Forum Terms & Conditions

    Formal disclaimer: any views or opinions expressed here are those of the poster and do not necessarily represent the views or opinions of The Creative Assembly or SEGA.
  • HellbenderHellbender Registered Users Posts: 32
    edited August 2016
    Matthias,

    Is it possible that the campaign battle desyncs are related to a large number of artillery pieces (4+) on the battle map?

    It seems to be in line with my findings:
    • Only starts happening more frequently late game, since the early game seldom has a large number of artillery present on the battle map
    • Usually happens during siege battles, especially during large engagements with artillery firing together or at each other
    • I witnessed a desync happen at the very moment a previously routing artillery unit regained its equipment

    I've now fought a number of very large coop engagements (60+ units on the battle map) of Greenskins / Vampire Counts against Chaos with only 2 Hellcannons present. These battles did NOT desync.

    A small engagement of Vampire Counts against Brettonia armed with 4 Trebuchets caused a desync during heavy artillery fire, some 5 minutes in. On a second attempt, a desync happened after a previously routing artillery unit regained possession of their equipment, about 6 minutes in. We finally were able to play out this battle on our third attempt, by routing all enemy artillery within the first 2 minutes of play. The battle then continued without problems, and lasted around 10 minutes.

    Could someone else confirm or reject this theory?


    Desync report attached, I can provide a savegame if needed.
  • LoadingplswaitLoadingplswait Junior Member Registered Users Posts: 14
    edited August 2016
    Hi Hellbender,

    I can't confirm nor reject your theory, although I have a theory of my own, written in our own thread.

    https://forums.totalwar.com/discussion/182101/desync-problems-after-bought-dlc#latest


    "After the patch we fought around 5 battles real-time. The 5th time we desynced, cleared battlePref cache. Desynced again with the next try.

    The only thing that has changed in our armies since the last RT battle that did work was a chaos fire mage in my army. Our army roster hasnt changed exept for him.

    Taking the mage out doesnt help so I doubt he's the problem. Although this is the second time we start desyncing after gettin a chaos mage on the campaign map. Coincidence??"



    Our desyncs start occuring after adding a battle ( fire ) mage to my chaos army. This happened in 2 different (!) campaigns. First battle after adding, resulted in desyncs, both campaigns.
  • SnurteSnurte Registered Users Posts: 9
    Hi Matthias,

    The attached save is from the turn before it happens. When we end it the Greenskins attack as I mentioned in my explanation of the issue.
    Are you saying you weren't able to recreate and need a new example or do you actually need several save up to the point it happens?

    Regarding the other users theories, none match our situation. By turn 9 we didn't have a lot of artillery even though one of us were playing Dwarfs and we had no chaos mages around.
  • HellbenderHellbender Registered Users Posts: 32
    @Matthias, here's another savegame set for the devs to try out.

    We can easily reproduce a desync in the quest battle that follows this turn. Here's how to get to it:

    > End current Greenskins (host) turn
    > Launch quest battle for the Vampire Counts (client) using "Teleport" with Mannfred von Carstein
    > The quest battle is the final one in the Armor of Tempelhof quest line and features Bretonnia with 4 Trebuchet units
    > We are getting desynced unless all the Trebuchets have been routed within the first few minutes

    @Loadingplswait and @Snurte, thanks for letting me know that it's not just related to artillery. It does seem that adding certain units to the battle really increases the likelihood of desync.
  • KuikkaKuikka Junior Member Registered Users Posts: 64
    Constant battle desyncs here as well.

    Last campaigns ended in campaign desyncs and crashes, and the latest hotfix didn't work in ongoing campaigns so we started a new. Chaos and beastmen.

    This campaign is suffering from occasional campaign turn desyncs but most annoyingly, battle desyncs. We didn't have this problem before the latest hotfix. We click "end battle" and it desyncs and exists to main menu. Today two big battles flushed down the toiled thanks to desyncs. Two hours wasted today alone. HOW FRUSTRATING IS THAT.

    CA FOR CHRISTS SAKE, this game is UNPLAYABLE! We can't finish even one campaign!
  • Matthias CAMatthias CA Administrator UKRegistered Users Posts: 2,580
    Hi everyone,

    I am really sorry for the length of the frustration caused by this issue.

    Thank you for all the information provided. We think we have finally managed to succesfully reproduce it.

    This has been forwarded to our devs now.

    Thank you all for your patience,

    Matthias
    PLEASE READ THIS THREAD BEFORE POSTING YOUR ISSUE ON THE SUPPORT FORUMS.

    Need to contact us?

    Forum Terms & Conditions

    Formal disclaimer: any views or opinions expressed here are those of the poster and do not necessarily represent the views or opinions of The Creative Assembly or SEGA.
  • ImbazilImbazil Registered Users Posts: 64
    We had the same issue yesterday, and got desync 9/10 times when playing the battle ourselves.

    However we deactivated the beastmen DLC in steam and started a new campaign, no desync yet and we played many battles over about 30 turns so far, so im hopeful.
  • HellbenderHellbender Registered Users Posts: 32
    Unfortunately we are still getting desynced. My previous theory about artillery appears to be incorrect.

    Getting a desync with Dwarfs defending against Vampire Counts at turn 15. No artillery present on the map. The battle desyncs as soon as the armies clash. Savegame attached.
  • PhiPhi Registered Users Posts: 11
    Is there any update on this issue?

    A friend and I allready had to abort our last Coop-MP game at turn 160, because of the Chaos invasion bug where he couldn't finish his turn after I obliterated the Everchosen.

    Now we bought the beastmen DLC and the next Coop-Campaign we tried we are having this desync problem every time we play a Chaos Quest (the one with the sword I think) battle.

    This is really a huge turnoff. We quite simply don't have unlimited time to play and not being able to finish a single game is just unacceptable. We are both playing Total War games since Shogun but Warhammer feels like we have been degraded from paying customers to beta testers.
  • ImbazilImbazil Registered Users Posts: 64
    Have you tried what i wrote above? Our campaign is still going with no desyncs so it would be nice to har if it works for others as well. Only drawback is that you cant play as the beastmen :(
  • PhiPhi Registered Users Posts: 11
    Imbazil said:

    Have you tried what i wrote above? Our campaign is still going with no desyncs so it would be nice to har if it works for others as well. Only drawback is that you cant play as the beastmen :(

    Sadly, that is not an option, because my mate plays on Beastmen and I play on Chaos. We are actually fans of the Warhammer Fantasy tabletop as well and specifically bought the Beastmen-DLC so we could play a Coop Campaign that has a more lore-friendly alliance. Just to add a bit of flavour to our gaming experience. But that flavour turned bitter.

    I was really looking forward to other new races and especially the Dark Elves DLC (if there's even gonna be one), but as we couldn't finish even a single Coop Campaign as of yet -due to no fault of our own- that would defeat the purpose of having fun. It's not like beta-testing software and having to Register on Forums is something I enjoy doing in my free time. That post from Matthias CA where he asks players to save the game every turn until the error occurs is pure gold. How about a salary, then I'll do it. ;)
  • HellbenderHellbender Registered Users Posts: 32
    edited August 2016
    Imbazil said:

    Have you tried what i wrote above? Our campaign is still going with no desyncs so it would be nice to har if it works for others as well. Only drawback is that you cant play as the beastmen :(

    Imbazil,

    Although we've both bought the Beastmen DLC, we've deactivated it through the Steam "Downloadable content" menu by unchecking "Install". However, this doesn't remove the Beastmen from the main campaign, it only makes it so that you can't play the faction.

    We had no desyncs on our Orcs/VC campaign prior to release of the Beastmen DLC. When the Beastmen DLC was released, we started getting desyncs, even though we had started our campaign before release, and had no Beastmen on the map.

    We are now playing a new campaign with Humans/Dwarfs, and are hence for the first time encountering Beastmen. We're also getting desyncs fighting other factions. So as far as I'm concerned, the desyncs are definitely related to the patch which introduced the Beastmen DLC, but not the Beastmen themselves.

    The only temporary fix we've found so far is quicksaving right before the battle (on the battle initiation screen where it shows the armies and balance of forces), quitting the game, sending the HOST save game to the CLIENT, then loading the quicksave again. This works for one battle. The next battle will still desync.

    As far as I'm concerned it's a valid workaround, but it's annoying as heck, and CA should still investigate further to restore game stability back to pre-Beastmen DLC levels.
  • ImbazilImbazil Registered Users Posts: 64
    I agree that a hotfix for this is badly needed. Too bad the above didn't solve it for you, even if unticking the DLC doesn't removed the beastmen we have not gotten a single desync yet since we did. Not sure why (Could also simply be luck).

    It does however obviously disable the beastmen team, which was the team I paid for and had intended to play.
  • Matthias CAMatthias CA Administrator UKRegistered Users Posts: 2,580
    Hey everyone,

    Just to confirm we are aware of this issue and are working hard on it.

    We fully understand the frustration and apologies for the inconvenience caused by this issue.

    Matthias
    PLEASE READ THIS THREAD BEFORE POSTING YOUR ISSUE ON THE SUPPORT FORUMS.

    Need to contact us?

    Forum Terms & Conditions

    Formal disclaimer: any views or opinions expressed here are those of the poster and do not necessarily represent the views or opinions of The Creative Assembly or SEGA.
  • KuikkaKuikka Junior Member Registered Users Posts: 64
    We bought new graphics cards just to enjoy this game better and now it's just waiting and waiting :( hopefully it'll get fixed soon.
  • KuikkaKuikka Junior Member Registered Users Posts: 64
    Next DLC already coming and the previous patch + DLC left the coop game in ruins... How can CA expect us to pay for next ones if we can't even play them??
  • KytonKyton Junior Member Registered Users Posts: 4
    I also have this problem. Seems that it often desyncs in the battle once using a skill/spell on a hero or general unit. The only way we've managed to "recover" is to have the host send the save file to the 2nd player and have them overwrite their save (in the name/appdata/roaming/the Creative Assembly/Warhammer/save_games_multiplayer folder).

    Unfortunately, that only gets us through that battle on reload, and maybe a few more turns, and then one of us will desync again 3-5 battles further in the campaign. We can usually fix it by replicating the save overwrite but it is REALLY annoying to do every 15 or so minutes and doesn't seem to really fix the root of the problem.

    This is really disappointing to me as prior to the Beastmen patch we were able to play co-op campaigns without issues...which surprised me as in past recent total wars it usually takes 1 year before the games are stable enough to play....and I really liked being able to do the co-op games. I usually play 90% of the time with my brother rather than single player. We managed to finish about 4 campaigns together pre patch, and only once post-patch (by doing the constant save replacements)....and have given up on several more. Frustrating!!!
  • PresceltoPrescelto Junior Member Registered Users Posts: 5
    +2 there, same problem. Desyncs clue: once on change turn, one on smashing the gate of a town and one on ok flag after auto-resolve..

    :neutral: help us
  • SnurteSnurte Registered Users Posts: 9
    edited August 2016
    Thanks for the link!

    I hope it's included in the 'various desyncs' since there's not much point in playing the campaign until the bug is fixed.

    *keeping my fingers crossed*
  • KuikkaKuikka Junior Member Registered Users Posts: 64
    edited September 2016
    STILL DESYNCS DURING/AFTER COOP BATTLE!!!! we can't play a SINGLE battle without game desyncing when we press "end battle" and game returning to menu! Countless hours wasted again.

    Now I'm really **** off. Our campaign was paused for weeks and the fix wasn't a fix at all.
  • HellbenderHellbender Registered Users Posts: 32
    Kuikka said:

    STILL DESYNCS DURING/AFTER COOP BATTLE!!!! we can't play a SINGLE battle without game desyncing when we press "end battle" and game returning to menu! Countless hours wasted again.

    Now I'm really **** off. Our campaign was paused for weeks and the fix wasn't a fix at all.

    :/

    This sucks.

    Could you do a quicksave swap right before the battle (exit game, host sends quicksave to client, client overwrites existing quicksave, reload quicksave, play battle)? This should keep this battle from desyncing. Then have a look and see if the next battle doesn't desync anymore.

    I haven't had the time to play the new update yet, and I won't be able to do so for a couple of days, so I can't comment further.
  • LoadingplswaitLoadingplswait Junior Member Registered Users Posts: 14
    edited September 2016
    Have you started a new campaign or loaded a save?

    Might be that the problem before the fix is rooted deep in the saves, thus the saves are "corrupt"

    If so.. try starting a new MP campaign and see what happens..

    Hope this works.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file