Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.


User Info RequiredMultiplayer compatibility error

WolfOfUlric225WolfOfUlric225 Registered Users Posts: 2
edited August 2016 in Multiplayer Bugs

Just recently i have tried to start a co-op campaign and multiplayer battle with one of my friends and been unable to as of a 'compatibility error'. We are running the same mods / have the same DLC / same versions of the game/ we have even tried removing all mods. None of this has made any difference what so ever.

We have played co-op in the past and had no problems.

We have tried what advice has been offered on the forums and had no luck either i.e deleting the ClientRegistry.Blob in the main Steam folder, then re-start Steam, using run as administrator, and then verify your game cache. Reinstalling the game, running it vanilla.

Any advice on what i can do would be greatly appreciated!
Post edited by Matthias CA on


  • spikycspikyc Registered Users Posts: 1
    edited August 2016

    Just wanted to say that I had the same issue post-DLC launch. I've played with my brother many times before Beastmen launched. My brother and I have the latest version of the game installed, and the version on the title screen matches for both of us (V1.2.0). We have checked that we are both not opted into any betas, and we do not have any mods. We also both restarted Steam and then verified our game caches. However, the game still tells us that we are running different versions when either of us tries to host a game and the other tries to join. Any help would be appreciated. We get the same error whether we attempt to continue an existing campaign or launch a new one. I have the Beastmen DLC and he does not, if that helps.

    One other thing I noticed is that my Total War launcher has the ability to launch the game in Direct X 12, whereas his does not allow for that. We are both fully up to date with Steam updates. Not sure if this is related.


    EDIT: My brother is a moron and had mods but forgot. Problem solved.
    Post edited by spikyc on
  • Matthias CAMatthias CA Registered Users Posts: 2,580
    edited August 2016
    Hi WolfOfUlric225,

    Can you check out this FAQ that helps uninstalling all mods to see if the issue is mod related as mentioned by @spikyc?

    Post edited by Matthias CA on

    Need to contact us?

    Forum Terms & Conditions

    Formal disclaimer: any views or opinions expressed here are those of the poster and do not necessarily represent the views or opinions of The Creative Assembly or SEGA.
  • WolfOfUlric225WolfOfUlric225 Registered Users Posts: 2

    The FAQ didn't really help at all unfortunately :/ although it now works, we loaded it up today and where able to have a multiplayer battle which was great!

    Although when we try to start a multiplayer campaign the game loads and on completion of loading the game just crashes...

    Thankyou for your previous help but would you know hay this is now occurring?

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file