Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.


ATTILA Multiplayer Campaign Glitch

HazzballHazzball Registered Users Posts: 7
Okay so me and my friend went into a Multiplayer Campaign (No Mods) First we went into a CO-OP then Head To Head. When we got into the Campaign everything was working and was looking cool, Then we got into a battle, Unfortunately that wasn't fine, While we were both loaded in, It said "Waiting For Players To Join 299 Seconds Left" And the timer didn't count down and my friend was In the game as well as me, Obviously their wasn't a third player because it's a 2 player co-op campaign! So the timer didn't go down, I conceded defeat and then my turn ended and then my friend went in a siege and that was bugged too! Basically what happened here was, The timer "Waiting For Players To Join 299 Seconds Left" was COUNTING down this time, I was like "Oh, Great!" But when it hit 0 and we couldn't move ANY units or do anything. So We conceded defeat once more and re-hosted the campaign yet again!

This time I told my friend to change his Download Region to the UK and then we went back in the game and went in Head To Head, Configured all our settings, Verified Game Cache, Did all that nonsense, This time the Land Battles Worked! But the Sieges didn't.. Honestly we could just auto resolve all of this but we want to fight some of the battles we know we can win on the battlefield.

It worked for my OTHER friend and I perfectly, Although he was from the US, We had similar problem but he changed his download region and VPN to the UK, And with this other guy I'm playing with it didn't? Not sure if this is a known bug for Multiplayer Campaign but would love it to be fixed because this is a huge issue for Multiplayer Campaign and that's the main reason I come onto ATTILA for. The Multiplayer Campaign!

Well, If others have the same glitch please reply to this post and let it be known to all! & Devs, Please fix this glitch, It's really annoying and needs to be addressed.

NOTE: I've posted this in the other sections but no one has replied or given me any solutions to this bug, So I'll post it here and hope someone replies..
Sign In or Register to comment.