Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.


Windows 10 error

spartanchspartanch Registered Users Posts: 1
I have had Rome 2 Total war for a few years now and when I upgraded to windows 10 I originally had no issues. A few months ago the game quit starting. I hit play in Steam and the launcher pops up. I hit play and the launcher disappears and in Steam next to the Rome 2 Total War title it says "running". After about 10 seconds is stops saying "running" and nothing happens.

I have tried everything from the forums and online. I even went through Steam support until they referred me to Creative Assembly support. I tried everything they told me and none of it worked so they told me to post here. Please help I haven't been able to play the game in months and I have about $90 put into the game.

This issue never happened before windows 10 and I let windows do the updates.


  • Jayhawk301Jayhawk301 Registered Users Posts: 1
    this worked for me I had same issue you had I found this in Steam forums for Rome 2.

    -When booting up the game, when you see the windows icon on your mouse, click nothing! if you do it will crash, boot up, wait 30 seconds and let it do its thing.

    If it still does not work:

    -Remove all mods (first uncheck off the launcher, if it does nothing, unsubscribe through steam workshop) then reboot the game.

    If the above fails to work follow these steps:

    -Go to "C:\Users\Administrador\AppData\Roaming\The Creative Assembly\Rome2"

    -Then delete the Rome2 folder.

    -Once removed go to "C:\Program Files (x86)\Steam\SteamApps\common\Total War Rome II\redist"

    -Then open the files listed below in that order and click on repair for each one, the last one doesn't have a repair window pop up, instead you will see a small loading bar,


    Then just proceed to load your game and it should then go onto the main menu.

    Basically a file save of settings which corrupts at random it seems. Reinstalling the game wont do anything as these files save locally.

    Be aware that in the Users/roaming Rome 2 folder are your local save files, you may want to make a copy of these or just copy the entire Rome 2 folder which the guide asks you to delete. A friend recently fixed his game using this when it stopped working earleir today after 130 hours play time.

    If you are unable to find the app data file then you will need to enable view of hidden files/folders. 

    For windows 7 go to control pannel, folder options, view tab and enable show hidden files and folders.

    For Windows 8 go to the control pannel app, scroll to the bottom and select the More Settings. Then click on appearance and personalization, look under the folder options category and check the show hidden files/folders.

    If you have hidden files/folders enabled and still dont see it make sure your looking at the User profile your currently logged into windows with.

    Hope this helps! good luck

    If that doesn't work, i may have found a solution to the crashes related to Patch 9.
    My game crashed at startup since Patch 9.
    Some other games had this issue aswell so i tried following, with succes:
    -Go to %appdata%/Roaming/The Creative Assembly/Rome2/Scripts/
    (Start > search bar > %appdata%)
    -Open: preferences.script.txt
    -Search the following (CTRL + F): directx
    -You should find the following line: 
    gfx_enable_directx11 true; # gfx_enable_directx11 , Enable DirectX 11 rendering #
    -Change the "true" to "false", so it looks like this:
    gfx_enable_directx11 false; # gfx_enable_directx11 , Enable DirectX 11 rendering #
    -Save and close the file.
    -Launch the game, and it should hopefully work :)

    If you do not have any files in the /scripts/ folder, please download my preferences.txt and place it into the /scripts/ folder.
    Make sure to change the settings to your liking once you are at the ingame Main menu.
    Change the "(DOT)" to an actual dot . this is to prevent Steam from removing the link.

    If you do not have ANY folder in %Appdata%, please download the following and extract it to your %Appdata%:

    NOTE: the line may look different from the above example. But it should look familiar.
    For me, the line looked like this:
    Which i changed to:

    This disabled Directx11.
    So the game might not look as pretty, but atleast it works.
    We'll have to wait for CA to fix the issue with Directx11.

    Hope this works for you :)
    If it did, please leave a reply so the topic will stay on the first page.
    Last edited by Mastaloui; Jun 28, 2015 @ 4:02pm
  • VictoriousVictorious Registered Users Posts: 11
    I've been having a similar issue though I'll be in the middle of my game. Screen goes black whether it's from playing in a battle or ending my turn. Screen goes black or just goes straight to my desktop, and the game shuts down. It's very dissapointing. When I get home tonight I'll try your options to see if it works.
Sign In or Register to comment.