Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

Memory leak on DX12 with R9 390 and latest drivers/patch

SenryakkuSenryakku MemberRegistered Users Posts: 37
Build: 12678.0

Detailed description : My game crashes in like 2 minutes... I only have 8 GB of ram and the game will uses up to 4gb in a matter of minutes, while being idle in the menu screen...

This is the first time I actually have this kind of memory leak on this game.
There is no dump file, the game simply stops to respond once I've reached 100% memory used.
I rolled back to dx11 but the FPS obviously dropped :neutral:

Reproduction Steps:

-launch game with dx12
-crashes because of memory leak

Comments

  • CAMichaelBeirneCAMichaelBeirne Creative Assembly Registered Users, CA Staff Mods, CA Staff Posts: 94
    Hi Senryakku,

    If you opt into the previous build "Patch4" in the public BETA, and use DX12, do you still get this issue in the previous version of the game?

    How to opt into the "Patch4" Public BETA:
    1) Right-Click Total War: WARHAMMER in the Steam Games Library.
    2) Select Properties, and go to the BETAs tab.
    3) In the "Select beta you would like to opt into" drop-down list, select "patch4 -".
    4) Close the porperties windown and the game will update back to Patch4.

    You can opt out of the BETA again at any time.

    Please reply here if DX12 works or does'nt work in Patch4.
    Formal disclaimer: any views or opinions expressed here are those of the poster and do not necessarily represent the views or opinions of The Creative Assembly or SEGA.
  • AmecarethQcAmecarethQc Registered Users Posts: 5
    edited December 2016
    Just for the info, I actually have this problem since patch 4 (could be older than that though) as well, again, only on dx12. I have a amd rx 470 with the most recent driver
  • SenryakkuSenryakku Member Registered Users Posts: 37
    edited December 2016
    Rolled back to the patch 4 and everything seems stable, dx12 works. I Hope you guys will be able to resolve this DX12 issue for my card... I assume not the whole player base is touched by this problem as I haven't seen much people talking about it.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file