Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.


SolvedSOLVED DirectX 11 Crashes on Start since Elves, but not DirectX12?

NoisdikaNoisdika Registered Users Posts: 18
edited January 2017 in Crashes

If anyone has any suggestions or solutions to this I would be very appreciative.

My problem began after the Elves dlc release. I didn't play Total War Warhammer until probably 3 weeks after the dlc release, but I noticed my game would crash before reaching the intro video when I ran it using DirectX 11.

Prior to the dlc update I played Warhammer on DirectX 11 just fine. I prefer using DirectX 11 because the game runs better on that versus 12. I have a Nvidia GeForce GTX 980 and performance comparisons have confirmed the game does run better on 11 than 12.

I followed the original Elves dlc hotfix suggestion and nothing changed. I also disabled Razer synapse suggested in a separate thread and no luck. Strangely, after playing Warhammer for am hour or two on DirectX 12, closing the game and then reopening it running on DirectX 11 worked successful a few times, but it hasn't been consistent or successful since.

I may just be very ignorant and oblivious to something anyone else might see or realize, but Id really appreciate anyone's help with this if they've experience a similar problem or have any suggestions in general. It may not seem like a big deal, but I definitely notice a difference in how smooth the game runs on DirectX 11 versus 12, at least for my computer.

- Noisdika
Post edited by BillyRuffian#6250 on


Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file