Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.


Can no longer recruit Elite Nubian Archers or Infantry Shotelai

ShiakouShiakou Registered Users Posts: 1
edited March 2017 in Gameplay Issues
When one of my armies got wiped out, I tried to reinstate its legacy. I've built up Alexandria to be my main troop producing province and maxed out the unit buildings there for both infantry and cavalry.

Suddenly I can't recruit Elite Nubian Archers or **** Shotelai anymore. They're not greyed out, the unit cards are just not there.

I've recruited them before, and many of my other armies still have those units.

Is this normal? Will I have to play the rest of the game without those two units?


Issue has been answered and solved elsewhere. Thank you for your time.
Post edited by Shiakou on


Sign In or Register to comment.