Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

SolvedWarhammer Crashing

Eradicator8Eradicator8 Registered Users Posts: 2
edited June 2017 in Crashes
Build Number: 13578.1041534

Description: On the launcher it mentions that it thinks my display drivers are out of date, not true so I press play. After that a black screen comes up with the windows circular loading mouse icon and ultimately "Total War: Warhammer has Stopped Working" pops up. At the risk of distracting from the original problem I've noticed if after I press play I bring something else like Steam to the foreground with Warhammer now in the background it will actually load into the main menu and can be played. The issue being at this point the game is very unstable and there's a phenomenon involving the the frames, not sure how to explain it but it's unplayable as it would strain the eyes. Under normal conditions though the game crashes on startup.

P.S
dump file was too big so I took screenshots, hope that works.





Post edited by BillyRuffian on

Comments

  • BillyRuffianBillyRuffian Moderator UKRegistered Users, Moderators, Knights Posts: 39,962
    The thing with the out of date display drivers occurs because the game is looking for drivers no older than two or three m,onths. Your Intel driver is from April 2016 and the Nvidia one is from August 2016. The most recent Nvidia one was released this month. This may always be an issue if you are using a laptop that requires customised drivers. If those are not customised drivers try using the new Nvidia ine here http://www.nvidia.co.uk/download/driverResults.aspx/120052/en-uk.

    Another discrepancy occurs in your preferences script which is showing your graphics card as an Nvidia 690 not the 860M that appears in your Dxdiag. Did you, by any chance, copy the preferences.script from elsewhere?

    The issue you mention with being able to load the game in the background occurs most frequently with out of date Razer software (of which I see no evidence in the information provided) but may also happen if you are running tweaking/optimising/streaming software such as Nvidia Geforce Experience. Are you using any of those types of software?

    Other reasons for it can be related to permissions in the Steam folder, clogging of the Steam download cache, and missing or corrupted files. Have you tried repairing you Steam library folder, clearing your download cache, and verifying the game's integrity?

    PS: It woiuld be better if you just zipped the dump file to upload it. I should also point out that Viisual Studio can sometimes mess with the game.

    "He uses statistics as a drunken man uses lamp-posts - for support rather than illumination." (Andrew Lang)

    |Takeda| Yokota Takatoshi

    Forum Terms and Conditions: - https://forums.totalwar.com/discussion/172193/forum-terms-and-conditions#latest

    "We wunt be druv". iot6pc7dn8qs.png
  • Eradicator8Eradicator8 Registered Users Posts: 2
    Thanks for your swift reply. To start with I downloaded the driver and and performed a clean install. Since I had the GeForce Experience installed I also uninstalled that. I also changed the 690 in the preferences.script to be 860m, and yeah I got that off another form post while trying to fix this last night. I did it last night but it's easy and for the sake of being through I cleared the download cache.

    After a restart I booted up the game to see the same driver message but, proceeded to hit play. The game started without crashing, I then tried changing the resolution as that would cause the game to crash before and that also worked without crashing. Tried a quick skirmish but the frame issues were still plaguing me but turning vsync on fixed that problem.

    So after some additional testing as well a good long play session I'll say the issue seems to have been fixed. Thanks for the reply it turned out to be super helpful!
  • BillyRuffianBillyRuffian Moderator UKRegistered Users, Moderators, Knights Posts: 39,962
    edited June 2017
    Glad it helped.

    You'll still be getting the driver message because you also have an Intel graphics driver, and they don't always update their's so often. You could try searching their site for a newer one, which might remove the message.

    Anyway, I'll mark the matter Solved as everything seems to be working now.

    "He uses statistics as a drunken man uses lamp-posts - for support rather than illumination." (Andrew Lang)

    |Takeda| Yokota Takatoshi

    Forum Terms and Conditions: - https://forums.totalwar.com/discussion/172193/forum-terms-and-conditions#latest

    "We wunt be druv". iot6pc7dn8qs.png

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file