Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

Monster Hunts Bugged.

Jam1507Jam1507 Posts: 3Registered Users
Hi,

Iv run into a bug on the Norsca DLC, specifically the Monster Hunts. I've unlocked the Monster hunts and began the Frost-Wyrm hunt. My quest was to raid the tower of karak. however I already owned this province so the game immediately aborted the quest step. I presumed that I would get a new quest location to raid and trigger the rest of the hunt.

However this hasn't happened , now I have no active quest, but in the book of hunts it says the Frost-Wyrm is still in progress making it impossible to do any of the monster hunts!

I know I could start again however I'm almost 200 turns in and if there is a solution then it might help others with the same issue.

Thanks in advance!
«1

Comments

  • JaycaspianJaycaspian Posts: 1Registered Users
    I'm having the same issue.

    The quest itself may also be bugged as I raided the province two turns in a row without getting quest progress. I think captured the city, wondering if that would trigger it, but then it turned into the problem you're having now.
  • wicket8115wicket8115 Member Posts: 115Registered Users
    I am having the same issue as above. The quest aborted when I took tower of Karak and no additional quests have popped up.
  • MarcusSkaaraMarcusSkaara Posts: 1Registered Users
    I also have the same issue. But i managed to raid the province and get the quest completed. I just never got the second part of it. Rest is same, cant do any hunt because "in progress".
  • Ghengisk_KhanGhengisk_Khan Posts: 263Registered Users
    I'm having the same issue only with the Traygar quest. I finished the first 2 but once i started Traygar and finished the first part now i have no way to continue.
  • SpartanGradSpartanGrad Posts: 1Registered Users
    Yep, same here as the original poster. I had the location captured, and it just wouldn't move forward from there.
  • Jam1507Jam1507 Posts: 3Registered Users
    Well it seems like a common fault with these new monster hunts. I wont bother restarting my campaign, and hopefully CA can get a hotfix to sort it!

    If anyone gets any progress please let us know!
  • Mandalay2Mandalay2 Posts: 50Registered Users
    Exact same issue here :(
  • JacabonJacabon Posts: 8Registered Users
    I already owned tower of karak and it still wanted me to raid my own province. i raided my own region for multiple turns and nothing..........
  • SnigeSnige Posts: 10Registered Users
    I have the exact same problem :/
  • NovantcoNovantco Posts: 8Registered Users
    As do I, it worked on my first play through but I had to restart as I screwed up haha. But now nothing! Please fix asap.
  • NovantcoNovantco Posts: 8Registered Users
    Well I restarted a couple of old saves and raided the region. It seemed to fix it. Worth a try for anyone that doesn't mind loading an older save.
  • lenimoz1lenimoz1 Posts: 19Registered Users
    Same here. Tried the Frost Wyrm challange. Playing as Wulfrik's Norsca faction. Seeing the bug popup to others, I tried to raid the region before capturing it. It was still held by the Varg, but the same problem happened. The quest popup showed, but didn't progress and the next step didn't show up. Now I will probably restart again, but yeah... it seems the Monster hunts are bugged.
  • dge1dge1 Moderator Arkansas, USAPosts: 18,284Registered Users, Moderators, Knights
    Support will not be able to assist without you providing additional information.

    Use this link as a guide:
    https://forums.totalwar.com/discussion/173609/guide-to-posting-in-campaign-and-battle

    Also, if will help them tremendously if each of you would post your issue in your own thread.

    Thanks.
    "The two most common things in the universe are Hydrogen and Stupidity." - Harlan Ellison
    "The right to be heard does not automatically include the right to be taken seriously." - Hubert H. Humphrey
    "Never argue with an idiot. They will only bring you down to their level and beat you with experience.” - George Carlin
  • cranerDKcranerDK Posts: 1Registered Users
    Yep, same here as the original poster
  • wicket8115wicket8115 Member Posts: 115Registered Users
    Build 1.6
    Running with all mods disabled

    I did a quick restart to recreate the bug. My save file is right before it happens. So the issue is I have selected the frigustrex monster hunt and it gives a mission to raid the tower of Khrakk. If you attack and occupy the settlement before raiding it will give a message that you have failed the mission. From there you are stuck. It does not advance you to the next step in the mission chain without the rewards and you cannot start any other monster hunts. I will create another thread as well. If there is more info please let me know.
  • wlabuddawlabudda Posts: 1Registered Users
    i have take the quest with make a raidlager in the region of the tower before i attack the village.
  • ScrandasaurusScrandasaurus Posts: 1Registered Users
    Hi Guys, I found an easy solution to this. I had the same problem, only it would not trigger because the Tower of Karak region was ruins. I had Wulfrik raiding the ruins region, saved, exited game, restarted but DISABLED all mods. As soon as next turn rolled around the raiding triggered and the quest advanced. Hope this helps!
  • keetjinkeetjin Posts: 6Registered Users
    Seems like i'm not the only one with this problem. Same, quest asked me to raid Baersonling camp, for traygard mountain cleaver. I confederated the holding faction, quest failed. Stucked now. Please help.
  • wicket8115wicket8115 Member Posts: 115Registered Users
    Scrandasaurus did you ever get the mission abort message before you raided? I am running with mods disabled but since the mission aborted it is not allowing for any progress.
  • javierdevicente95@gmail.com[email protected] Posts: 2Registered Users
    Same here. And I'm playing it with no mods
  • LazzorLazzor Posts: 3Registered Users
    edited August 2017
    same as above, no mods. still bugged.

    confederated them, then unlocked hunts, picked frigustrex, then cant even interact with any quests or other challenges.
  • datalink7datalink7 Posts: 1Registered Users
    Same here. Fresh install, no mods. Even tried raiding the province for several turns. In fact, I let rebellions wipe out the Towers so I didn't control the province any more. Still won't trigger.
  • GreyKnightDanteGreyKnightDante Posts: 339Registered Users
    edited August 2017
    Did you guys make sure you raided the right area of the province?


    You need to raid the lands EAST of the Tower of Kharak. Those lands west of the tower is the Bay of Blades land your raiding.

    blue is bay of blades territory


    red is Tower of Kharak

    --------------------------------------------------------------------------------------------------------------------------------------------------------------------------------


    Hello I am an admin from the Warhammer Wiki. Please feel free to give any suggestions on how to our improve at this forum thread here! ANY help or suggestions is welcomed!

  • Galvinized_IronGalvinized_Iron Posts: 822Registered Users
    Had the same issue. The monster hunt became uncompletable after conquering the Crack Tower. At that point I got a message that it failed, but it remained active.

    No mods installed.

    Restarted the campaign because of it. Was on a legendary, so I deleted that autosave when starting a new one. Next campaign I made sure not to reproduce the situation and then it works, so the bug must be tied to conquering the province.

    Did you guys make sure you raided the right area of the province?


    You need to raid the lands EAST of the Tower of Kharak. Those lands west of the tower is the Bay of Blades land your raiding.

    blue is bay of blades territory


    red is Tower of Kharak

    Obviously I checked that. This is hardly the first quest that require you to be in a specific province. All you need to do is to hover the mouse over the terrain to see where you are.
  • Mephasm_ShadowenMephasm_Shadowen Posts: 8Registered Users
    edited August 2017
    I have run into the same issue where I was sent to raid Bearsonling's Camp to begin the 3rd hunt. Right before I arrived the WoC razed it to the ground, I then got the message that the quest was abandoned.
    At this point all other tribes were dead thus no one but me could colonize it, so I ended up doing it myself.
    The quest will not reappear nor activate, and it still says I'm on said hunt so cannot change to another.

    At this point I'm on turn 160 without change or progress at all, hopefully a hotfix can fix this issue without having to restart. :/
  • XvimXvim Posts: 2Registered Users
    I had a very similar issue. I was able to raid the tower even while owning it, but upon taking Baersonling's Camp while on the hunt for Treygard, Mountain-Cleaver the quest was abandoned. The hunt log remained locked as I am already on a hunt, I can not challenge another.
  • CrazyPhilCrazyPhil Posts: 2Registered Users
    I have the same issue
  • wicket8115wicket8115 Member Posts: 115Registered Users
    There is a mod out there called instant monster hunting for those starting a new play through. It is made by the same modder who does the instant quest battles and instant quest items. It unfortunately will not help if the quests have been started but I like them since they will keep the quests from bugging out for the reasons stated above.
  • CrazyPhilCrazyPhil Posts: 2Registered Users
    Anyone found a fix to this yet? my hunts are still locked on the Frost Wyrm challange after raiding Tower of Kharak
  • ddelosddelos Posts: 2Registered Users
    Same as above. I confederated the zone I was supposed to raid and the quest cancelled but the Hunt is still in progress which means my Legendary game is broken.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file