Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.


Monster Hunts Bugged.



  • HeavyMatthiHeavyMatthi Registered Users Posts: 2
    The same happened to me in turn 30 BUT 100 turns later I received the message that the scent of the dragon was picked up again and then I could finish the dragon quest and now I am on my mammoth :)

    So guys do not start anew with your campaign but instead continue!
  • lolFalconlolFalcon Registered Users Posts: 3
    It's a year later. This bug is still there. Started a new game on the Norsca on Warhammer 2. Took the monster hunt mission for The Tower of Khrakk region. Figured I'd beat my way to it, sadly kicked the hell out of Throgg thus making the area mine and aborting the quest, eventho it says "IN PROGRESS". Tried raiding the area with Throgg and Wulfrik to no avail. Do I really have to restart my game and pray every time I start a monster hunt that it doesnt stop working at the slightest change in the world?

    P.S. I dont use ANY mods, unless there is one that magically fixes this issue.
  • wicket8115#3703wicket8115#3703 Registered Users Posts: 189
    There used to be a mod for warhammer 1 for instant monster hunts mission that keeps this bug from happening. Not sure if it is available under warhammer 2 though. I would do a search for instant monster hunts if you are interested. Bummer though it would not work after the quest starts.
  • Dcoponen22Dcoponen22 Registered Users Posts: 1
    I had the same problem..All you need to do is raid the area for 1 turn, leave the area and raid South for one turn, then go back and raid for one last turn and it should correct itself...It worked for me
  • MavsynchroidMavsynchroid Registered Users Posts: 19
    edited May 2019
    Seriously?.... Years later and there's no fix for this?... Just ran into the problem myself.. First time I've been patient enough and done well enough to be successful so far in a campaign, and it's bugged...

    edit: aaaanddd the game crashed... -_- Should really work out the bugs in your games before spitting out new ones... Don't be such an ubisoft...
    Post edited by Mavsynchroid on
  • Bohemian11#4638Bohemian11#4638 Registered Users Posts: 9
    Still bugged even after 5 years, now i can restart my playthrough because of it, really shameful of you CA

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file