Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Is Ancient Empires comparable with DEI 1.2?

p.arbegust@gmail.comp.arbegust@gmail.com Posts: 7Registered Users
edited September 13 in General Discussion
Hello! Tried to load DEI 1.2 with the Ancient Empires and Ancient Empires UI and it froze. Still had some problems after disabling them but managed to fix it. Still wondering if they're totally compatible with 1.2 though. Hope so as I would like to run them. Dubious as they were last updated a year before DEI 1.2 released. Thanks for any help!
Post edited by p.arbegust@gmail.com on
Sign In or Register to comment.