Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

In ProgressGraphics are way too sharp

AggravatedPeasantAggravatedPeasant Registered Users Posts: 20
edited October 2017 in Performance & Graphics
Hello, I and a few others on the Steam discussions have been encountering strangely overwhelming sharpness in the graphics. I would like to further inquire on the official forums here if there is any fix coming, or if there is a workaround.

I will update the post with example pictures soon.

Link to the Steam discussion: http://steamcommunity.com/app/594570/discussions/0/1520386297683918549/

OFFICIAL RESPONSE FROM CA:

Hello everyone,

Apologies for the radio silence, as we have been hard at work testing various alternatives to resolve this issue for you. We weren't confident on posting until we had a confirmed solution, and to that extent I'm happy to announce that we have just that.

We're going to roll our changes out with Patch 1 which is due soon. This will include an option in the advanced graphics settings to enable or disable post-processing sharpening.

I'd like to thank you all for making us aware of this issue, and I look forward to hearing follow up feedback regarding our solution.

Kind regards,

CA_Matt

Post edited by AggravatedPeasant on
Tagged:
«1345

Comments

  • AggravatedPeasantAggravatedPeasant Registered Users Posts: 20
    Graphics settings, recommended using my gtx 1060 3gb: high
    Resolution: 1920x1080

    Nothing has been altered in any way, so it is just the default high settings.

    Pictures:





    I have attached my DxDiag, preference script and modified.log files.
  • Anon052Anon052 Junior Member Registered Users Posts: 16
    Yes the first thing I thought when playing was that there is a sharpening option activated. I tried looking in the options to deactivate it, but there was none.
    This makes the game uglier then TW W1 imho. I would be glad if you could deactivate it.
  • Blueeyesgirl3Blueeyesgirl3 Registered Users Posts: 285
    I've got it too, GTX 1060 here as well. Lowering the Gamma and/or Brightness takes some of the edge off but isn't a complete fix. It's not entirely annoying, but it's extremely annoying on the Lizardmen, who are really bright to start with.
    Team Lizardmen
  • AggravatedPeasantAggravatedPeasant Registered Users Posts: 20
    Most of my problem with this, is the campaign map. It almost hurts my eyes to look at certain things, especially when zoomed more out.

    It's okay in battles, but looks rather bad if you zoom out too.
  • DesariusDesarius Registered Users Posts: 2
    I have the same problem and it does not matter whatever I change in the settings. Lowering gamma helps a little but it just very very little.
  • lordmaximus77lordmaximus77 Technical Moderator Leeuwarden, NLRegistered Users, Moderators, Tech Moderators, Knights Posts: 3,348
    It looks the same on my machine. But I do believe it's meant to look like this.
    You could tweak the brightness & gamma to adjust it to your taste.
    Any fool can make things bigger and more complex. It takes a touch of genius – and a lot of courage – to move in the opposite direction. — Albert Einstein

    viri non urinat in ventum — Anonymous Roman

    TOTAL WAR FORUM: TERMS AND CONDITIONS
  • DesariusDesarius Registered Users Posts: 2
    It does not look the same on my friends computer...
  • lordmaximus77lordmaximus77 Technical Moderator Leeuwarden, NLRegistered Users, Moderators, Tech Moderators, Knights Posts: 3,348
    Could you post screenshots from his computer too then? I would like to see the differences
    Any fool can make things bigger and more complex. It takes a touch of genius – and a lot of courage – to move in the opposite direction. — Albert Einstein

    viri non urinat in ventum — Anonymous Roman

    TOTAL WAR FORUM: TERMS AND CONDITIONS
  • BrakierBrakier Registered Users Posts: 1,528
    edited September 2017
    if i put high on mine i get the same, i think thats how high looks, i play on ultra, might help if you fiddle around whit you AA settnings. in and outside of the game.

  • Blueeyesgirl3Blueeyesgirl3 Registered Users Posts: 285
    I don't know if it's related but I'm getting a strange crosshatching bug with some specific textures/effects. It's most notable with the infamous vortex, hopefully you guys can see it:



    Pretty sure the Vortex isn't meant to have that many holes in it. Other instances I've seen it include when ghost units die or a lord fades out after being wiped out.
    Team Lizardmen
  • AggravatedPeasantAggravatedPeasant Registered Users Posts: 20
    Brakier said:

    if i put high on mine i get the same, i think thats how high looks, i play on ultra, might help if you fiddle around whit you AA settnings. in and outside of the game.

    Another user on the Steam forums, Ruswarr, said that was not the case, and I quote:

    I seriously doubt that sharpening is even tied to any preset or curent setting. I set graphics to low and it did not go away.
    My only guess would be using FXAA instead of MSAA to try and blur it out, it sorta works.


    I've not personally tested it out yet, but I'm quite sure it would be the same for me regardless. I really hope it will be fixed somehow.
  • RuswarrRuswarr Registered Users Posts: 14
    It's not THAT much better on Ultra, and it's still noticeable. Everything looks fine in close-ups but as soon as you zoom out aliasing starts destroying smaller objects and I'm not willing to even try x4/x8 AA as I know I won't get stable enough fps that way. Currently the only way to somehow counter sharpening is FXAA but God I hate how FXAA blurs everything.
    I definitely had some aliasing going on in TWW1 (as, well, I'm not running 1440p or 4k resolution) with the same settings but the image was not that sharp. Here's a Grave Guard line for example; rain kinda gets in the way, but the image is nowhere as sharp as the one with DE troops.
    Getting an option to change sharpening would be very much welcome.



  • FeelTheHeatFeelTheHeat Registered Users Posts: 16

    I don't know if it's related but I'm getting a strange crosshatching bug with some specific textures/effects. It's most notable with the infamous vortex, hopefully you guys can see it:



    Pretty sure the Vortex isn't meant to have that many holes in it. Other instances I've seen it include when ghost units die or a lord fades out after being wiped out.

    I'm getting the same, we might have to wait for the patch, as long as my game doesn't crash/lose saves etc im happy for small bugs like that to get done later. Stability over small stuff like that any day
  • WestonG23WestonG23 Registered Users Posts: 4
    edited September 2017
    I believe they have either implemented post process sharpening or greatly reduced the aggressiveness of the FXAA. I notice a large amount of jaggies (aliased textures) with FXAA enabled. The original game's FXAA smoothed the vast majority nicely.
  • General_SandersGeneral_Sanders Member Registered Users Posts: 40
    I have the exact same problem and tweaking the gamma and brightness only helps slightly.

    Before seeing your post I thought maybe it was just something to do with my older gpu (760gtx) but evidently it's not an isolated case.
  • AggravatedPeasantAggravatedPeasant Registered Users Posts: 20
    edited September 2017

    It looks the same on my machine. But I do believe it's meant to look like this.
    You could tweak the brightness & gamma to adjust it to your taste.

    I dare say that the videos posted by the official Total War YouTube don't resemble the sharpness / pixelation that I get:

    Edit: Comparison with how my battles look.




  • AggravatedPeasantAggravatedPeasant Registered Users Posts: 20
    edited September 2017
    Be sure to have the pictures in full screen, as I'm playing in 1920x1080, so it looks even worse when viewed in full screen. It looks alright when zoomed to 100% from the forum site, but that's not how it actually looks for me.

    Just look at the last picture I posted, you can barely recognize anything amongst the blob of sharply drawn pixels along the lines of my units.
  • HorusHeresyHorusHeresy Registered Users Posts: 7
    edited September 2017
    Hello i have same problem

    I am using 970 and have last drivers, my settings is High/Ultra

    Post edited by HorusHeresy on
  • Komrad_MaxKomrad_Max Registered Users Posts: 6
    I have the same problem and it does not matter whatever I change in the settings.

    https://imgur.com/l4yx2TC
    https://imgur.com/1MYqyeT
    https://imgur.com/A2fdwNT
  • OnevfiveOnevfive Registered Users Posts: 2
    Having the same problem. The graphics are way too sharp. The world map looks especially bad. Lowering the gamma and brightness health a LITTLE bit but not enough for me to continue to play the game.
  • ShoknerShokner Junior Member Registered Users Posts: 30
    Yeah same here really bad sharpness, I know there trying to create a classic game but PAC-Man graphics is sooo 80's
  • Eddie62220Eddie62220 Registered Users Posts: 10
    Same problem here, playing with a 1070. I tried different graphics setup but always getting this weird / sharp / grainy / ugly graphics, even in ultra. I tried both FXAA & MSAA but always getting more or less the same quality...
  • KilnKiln Registered Users Posts: 3
    Same problem, and by Sigmar this is infuriating!
  • GorkDaMorkGorkDaMork Registered Users Posts: 1
    Same problem here, so glad I'm not the only one.

    The sharpness/contrast is way off and playing the game strains my eyes so damn much. This was never an issue with TWW1, nor any of the prior titles, nor any of the hundreds of games I've played through the years so I choose to believe that this is a bug rather than a design decision.

    Fyi my specs are: 1070, 6700k, 16gb, ssd - ultra w/ FXAA & a few things disabled for performance (depth of field, unlimited video memory etc). I just formatted my rig and installed the newest drivers before installing the game so it's not due to any custom GPU settings or old drivers.
  • Lord_HenkusLord_Henkus Registered Users Posts: 1,580
    I have the same problem! Do yiu guys notice also any lag? Warhammer 1 ran just fine with highest settings. So strange that this doesn't apply for Warhammer 2. Hopefully this wil get resolved before the mega campaign gets out
    How negative I may sound, game is stil 11 out of 10

    Also, please slow down combat!




  • Blueeyesgirl3Blueeyesgirl3 Registered Users Posts: 285
    Okay guys so I was up until the early hours of the morning last night messing around with the graphics settings and I may have a combination that almost eradicates the sharpness completely. I don't know if this will work for everyone as I'm assuming some of you will already have tried this but here's what I did:

    1. I set AA as high as it could go without causing fps drops - this was about 4x for me.
    2. I turned off screen space reflections, this seemed to be contributing to the armor's sharpness.
    3. I set texture filtering to trilinear. This may not be a direct link to the sharpness but it did help for me, so you can mess around with this one too - set it higher if you want, see if the other settings do anything different.
    4. I made sure SSAO was SWITCHED OFF. I know that this was recommended by people in other forums but all it does is make the sharpness look worse WHILE making your game look like you're playing it on an old Apple monitor from the 90's.
    5. Also, play around with the brightness/gamma until you get it to a level that suits you. This was actually the first thing I did lol

    It appears that the 'recommended' settings for our computers are not actually the recommended settings so we have to do some messing around on our own. Try these out if you haven't already.
    Team Lizardmen
  • AggravatedPeasantAggravatedPeasant Registered Users Posts: 20

    Okay guys so I was up until the early hours of the morning last night messing around with the graphics settings and I may have a combination that almost eradicates the sharpness completely. I don't know if this will work for everyone as I'm assuming some of you will already have tried this but here's what I did:

    1. I set AA as high as it could go without causing fps drops - this was about 4x for me.
    2. I turned off screen space reflections, this seemed to be contributing to the armor's sharpness.
    3. I set texture filtering to trilinear. This may not be a direct link to the sharpness but it did help for me, so you can mess around with this one too - set it higher if you want, see if the other settings do anything different.
    4. I made sure SSAO was SWITCHED OFF. I know that this was recommended by people in other forums but all it does is make the sharpness look worse WHILE making your game look like you're playing it on an old Apple monitor from the 90's.
    5. Also, play around with the brightness/gamma until you get it to a level that suits you. This was actually the first thing I did lol

    It appears that the 'recommended' settings for our computers are not actually the recommended settings so we have to do some messing around on our own. Try these out if you haven't already.

    Thanks, I'll try the combination out now :)
  • AggravatedPeasantAggravatedPeasant Registered Users Posts: 20
    This is the difference, it doesn't seem like a lot changed. I didn't touch the brightness and gamma, since it didn't really seem to change anything for me.

    Picture with recommended high settings:


    Picture with recommended settings by Blueeyesgirl3:


    It does seem to be taking some of the edges off, and I'll definitely be using these settings until there is something official.
  • Blueeyesgirl3Blueeyesgirl3 Registered Users Posts: 285

    This is the difference, it doesn't seem like a lot changed. I didn't touch the brightness and gamma, since it didn't really seem to change anything for me.

    Picture with recommended high settings:


    Picture with recommended settings by Blueeyesgirl3:


    It does seem to be taking some of the edges off, and I'll definitely be using these settings until there is something official.

    Yeah it definitely doesn't fix it completely, but I'm not getting a headache from all the sharpness anymore lmao! I'm glad it helps even a little. It could just be the settings need to be tweaked differently for every rig. My game almost looks like it does in all the streams now, compared to yesterday when everything was too bright/sharp. Try playing with other graphics options too, some people have been saying that lowering the texture quality can help a bit.
    Team Lizardmen
  • Komrad_MaxKomrad_Max Registered Users Posts: 6
    I think we mast wait official patch or fix :/

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file