Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.


65 hours: Bugs/fixes I found.

CommadosCommados Registered Users Posts: 23
Hey guys, so I have a few bugs I would like to submit so they can be fixed.

1. My intervention force spawned right near a Chaos force, once that Chaos force destroyed one of the ritual settlements, it just stood there (I presume to guard it from being taken back), but my intervention force also stayed there, and did not move even when I made the Chaos group a target. Is this because they are guarding that site from being taken again or is it a bug?

2. When my army disembarked as well as one of my heroes from sea, I could not move either of them. I tried on the next turn, but I still could not move either.

3. Once I took over this settlement, the ritual kept going. I know you are meant to hold a province, but id you were doing a ritual, and I killed the people in that settlement doing a ritual for my enemies, doesn't that mean the ritual stops? This seems inconsistent and means there is less stress about keeping those settlements going at all costs, rather than just keep them in your hands at turn 1 and 10/20 of your ritual.

5. Phoneix Guard units have been trained as the elite of the High Elves, and are meant to be unbreakable. Yet in their bio it says "the Phoneix Guard fight in without fear". However these units can rout and have their morale drop, they are not unbreakable. This is inconsistent, do they have fear or not? I believe they are meant to have unlimited morale on the tabletop.

6. Even when I press the forwards button, the camera will still pan to enemies/allies/neural targets. Can this be changed to not pan, and just get the turns of the AI done as quickly as possible please.

7. Heroes block the path of armies, and can be annoying when the hero has just completed an action, and the army has not got enough movement in the turn to go around the hero. Can this be changed please? This problem will coincide with problem 2.

8. Sometimes settlement names block army icons, can this be changed please to make it easier?

9. Sometimes units in guard stance will not fire their arrows properly, as opposed to of they are not in guard stance. This may be me, but can this be looked into please?

10. I fought this Skaven army twice on the battlefield, when I defeated it again the second time, it still ran away. Isn't the second fight after an army retreats meant to kill the retreating army if they loose? Unless I auto resolve the second fight, and unless I kill 100% of enemies in the second battle, this occurs.

11. Bolt Throwers still moved even though they were in guard stance, can this be checked please?

12. Malekith had the fireball ability in this match, and was able to fire them at will. 1 second cool down and 0 magic cost.

13. Armies tend to run past me a lot like this at full speed. I understand they have a goal, but these have eight turns to get to my city, and some do not. Can this be changed for them to be more risk adverse please?

14. Auto resolve is broken when Dark Elves vs Chaos. Both of these pictures were taken when I did a battle between Dark Elves and Chaos on hard campaign difficulty and hard battle difficulty.

Will be posting more when I fond them,



  • ITA_Vae_VictisITA_Vae_Victis Senior Member ItalyRegistered Users Posts: 2,002
    All I can tell you for a fact is that Phoenix Guards are not supposed to be unbreakable, so it's just a case of deceptive unit description.
  • frolof1frolof1 Registered Users Posts: 411
    Pheonix Guard would be broken if they were unbreakable. And if you have immune to psych it's kind of like without fear since you take no fear effects or terror.
  • General_Hijalti#1213General_Hijalti#1213 Registered Users Posts: 5,419
    For the ritual it won't end till it was meant to end, and the enemy have that amount of turns to take it back or the ritual will fail.
    For some reason it is impossible to declare war on the chaos ritual spawned armies for the other fractions, move an army up to one and click to attack it, the declaration war box will be greyed out. I'm not sure if this is a bug or meant to be this way.
  • acdoob20acdoob20 Registered Users Posts: 53
    That is a lot of stuff man. I'll touch a couple of them by number.

    1. you tried targeting the army. Did you try targeting the settlement?

    2. could you not attack the settlement also?

    6. The point of panning to other armies is to look at the location of different armies for tactical purposes. The speed up button just makes them run faster.

    7. is it the settlement that is stopping you? are you sure it is the hero? because I have never had that problem.

    10. Did both the battles happen on the same turn?

    12. The fireball in that case is an ability not magic, notice the number in the corner of the icon.

    13. The AI is supposed to get around you, you'd do the same right?

    14. The autoresolve meter has been broken forever, I they have never fixed, complain enough they might!

    It'd be great if you'd post your save games, if you have them at the moments of these events.
  • steam_164191850448yoMgfCpsteam_164191850448yoMgfCp Junior Member Registered Users Posts: 3,157
    6 you can use the last button in the top left of the screen to change how fast the camera is


    It's much easier and more fun to get engrossed in lore that takes itself seriously and tries to make sense within its own frame of reference.

    the reason I prefer LOTR over warhammer fantasy and 40k

    I am dutch so if you like to have a talk in dutch shoot me a PM :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file