Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.


SolvedLaptop - AMD Radeon 540 Discrete GPU not recognized - program insists on using Intel Graphics GPU

Adamus42Adamus42 Registered Users Posts: 2
edited October 2017 in Performance & Graphics
Warhammer 1 works perfectly automatically recognizing my Radeon 540 and running smoothly with reasonable FPS.

Warhammer 2 refuses to recognize the same GPU insisting on using the Intel 620 which makes the game unplayable.

Build: V.1.0.0 (4426.1184400)

Validating Game Cache.
Changing the line in the Preferences Script from Intel 620 to Radeon 540 (this auto sets back when the game is booted).
Changing the line in the Preferences Script GPU select criteria from 0 to 1 (and tried 2 too).
Using AMD Radeon Settings to launch Warhammer 2 (it recognises the game - as it does with Warhammer 1).
- Note this Radeon Card does not use Catalyst Control Center - it uses AMD Radeon Settings instead.
Resetting Warhammer 2 Profile in Radeon settings & changing Radeon global setting to turn on and turn off Global Chill.
Reinstalling Warhammer 2.
Changing Power Settings on Laptop (which is on mains power) to highest performance settings before launching game.
Going through all items on the Performance & Graphics official (& Google) discussion threads/boards regarding this issue.
Updated Radeon 540 Drivers (they were already latest versions).
Contacting AMD regarding this issue 5 days ago...no response from them on that yet.

All logs and docs and screenshot as requested attached. Love this game and would really appreciate a fix for this asap!

Post edited by lordmaximus77 on


  • acdoob20acdoob20 Registered Users Posts: 51

    hey man, I have an amd mobile graphics card and sometimes you need to go to the amd radeon settings, select system, sitchable graphics and then change running applications at the top right to installed and change the program to high performance.
  • Adamus42Adamus42 Registered Users Posts: 2
    Hey acdoob20...am new to AMD and missed out on that preferences tab in the bottom left of the Radeon settings (would seem more obvious to put that options in the gaming settings for Warhammer 2!)...using your input and that find I added Warhammer 2 to the Switchable Graphics Applications Settings (for anyone looking for where the application lives it is C:\Program Files (x86)\Steam\steamapps\common\Total War WARHAMMER II)...I set that app to High Performance...started the game up...and hey presto we have the AMD GPU recognized! Thanks so much.
  • acdoob20acdoob20 Registered Users Posts: 51

    No problem man, they made it more difficult to find that stuff since the recent updates and I have had AMD cards forever and took me 10 minutes to figure it out haha.
  • lordmaximus77lordmaximus77 Technical Moderator Leeuwarden, NLRegistered Users, Moderators, Tech Moderators, Knights Posts: 3,348
    Hi Adamus42,

    Good to see you got it fixed with the help of @acdoob20.

    It usually takes some time for AMD's mobile drivers to get updated profiles for switchable graphics for all GPU models. So in the mean time manually selecting it is a good fix.

    Marking this as Solved
    Any fool can make things bigger and more complex. It takes a touch of genius – and a lot of courage – to move in the opposite direction. — Albert Einstein

    viri non urinat in ventum — Anonymous Roman


Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file