Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.


Can't End Turn, Save Game, Move Characters/Armies in Mortal Empires as Dwarves



  • Darklighter44Darklighter44 Registered Users Posts: 3
    I am also using SFO.
  • jimbo_slicejimbo_slice Registered Users Posts: 4
    I just had this issue occur to me in a Vortex campaign playing with Malekith as my starting LL right after ending turn 170... couldn't even do a manual quicksave (ctrl+s), and going into the diplomacy screen froze up my game even worse (had no options under the "add / remove demands" button and once in the diplomacy screen I had no other UI option and couldn't exit diplomacy with the particular faction at all, quickload worked to bring me back to the last turn's autosave though).

    Restarted from my previous turn-end autosave and everything worked fine the second time around... not sure what caused this glitch, as I didn't have any events pop up (just a population surplus notification and one of my heroes leveled up), but I'm also running an assload of mods, so I probably shouldn't be surprised that weird things like this occasionally happen... still, first time it's ever occurred for me, thought it worth mentioning so people know it's not solely related to Grombrindal's Ancestors ability or the Mortal Empires campaign
  • ThaneMurthor12ThaneMurthor12 Registered Users Posts: 490
    Post saved games, post screenshots please.
    Khazukan Kazakit-ha!


    "In the centuries I have been the High King, our enemies have thought us weak, cowards hiding in the deepest, darkest places. Heh, fools! Every wrong is recorded. Every slight against us, page after page, etched in blood! Clan Gurnisson! Karak Eight-Peaks! Josef Bugman! The Urks must pay, Let them come..."

    "One wrong put right, yet the Great Book of Grudges...remains full..."

    - High King Thorgrim Grudgebearer.

  • obliviongrobliviongr Registered Users Posts: 9

    I've used it many times. I'm playing as Wood elves. Nearly any time an event happens, I get the freeze. Doing the save and load has worked every time.

    Ctrl-S doesnt work with me when the bug occurs.
    Also the diplomacy spam doesn't work either
  • gmircgmirc Registered Users Posts: 3
    Find the event in the history record menu and review it ,the record can be opened by click your faction mark on right above
  • benc85benc85 Registered Users Posts: 1
    Twice this happened, seems to be linked with the "Enemy of the Empire" event?
  • yaojiyueyaojiyue Registered Users Posts: 1
    Same Issue, I can't save or end turn after a battle.
    And also I can't use ctrl s to quick save, even I loaded the auto save file and fight that battle again, the game freezed still...
  • Myth1985Myth1985 Registered Users Posts: 1
    Still happening in September 2018. After the "Sword of Khaine Rests for now" event, I cannot move armies. Cannot save game.... come on CA. This is ridiculous.
  • Lord_Squirrel01Lord_Squirrel01 Registered Users Posts: 5
    after two years this bug is still going can you guys hurry up and fix your dam game. turn 30 of VC campaign tried everything and stuffed
  • JoetwobeardsJoetwobeards Registered Users Posts: 4
    edited January 2019
    I am also running into this issue. Twice in my Bellegar campaign (reloaded earlier save and chose different path in hopes to avoid, just happened 10 turns later) and once early on in my Kholek campaign. This is seemingly a new bug and not sure what would have caused it mod wise, but SFO seems to be a common mod in this thread but also im experiencing the issue nearly 2 years after this thread was made. Hope some resolution is found soon with upcoming Festag patches from both CA and SFO.

    Running SFO 2, Darker Grabd Campaign, Better Trade, UI Modding Framework, Region Trading, Home Region Movement Bonus, building progression icons 2, improve loading screen icons, tier 4 minor settlements, faster end turn camera, better camera mod, community bug fix, community moulding framework, several Dryrain's Reskins, GCCM's several mods, and immersive battle banners.

    Update: found on another thread. By breaking my alliance with The Empire, my turn starts with Ostermark declaring war on Norsca. After that everything is fine. Seems that something with that war prompt is bugged if you're allied with the Empire.
    Im cool with work arounds as long as I don't need to scrap hours of game time.
    Post edited by Joetwobeards on
  • BumberbogBumberbog Registered Users Posts: 1
    This bug is still happening, Jan 2019. Turn 14 with Ugrim Ironhammer. The Ctrl-S, Ctrl-L workaround doesn't work because one can't save the same, whether with a menu or with the shortcut. Still have not found a way forward.

    It's apparently a couple of events happening together that cause it, not mods. I'm convinced of this because I've been using the exact same mods for a couple of full games now, not having added or deleted any. Then suddenly the game is broken?
  • hammerhand48hammerhand48 Registered Users Posts: 9
    Just jumping on here 1/31 of 2019 having the same issue playing as Grombrindal. CA... NOTICE THIS AND FIX IT!
  • jscrizzjscrizz Registered Users Posts: 1
    I am also having this problem at turn 60 on clan agrund campaign. Super annoying
  • jimmywat87jimmywat87 Registered Users Posts: 2
    Thank you so much for the CTRL S then CTRL L info, had numerous campaigns ruined at various number of turns.
  • gregorisnov47gregorisnov47 Registered Users Posts: 1
    I just got the same issue as well :( turn 27 with Lokhir Fellheart. Can't use ctrl+S because you're not allowed to save. And using the diplomacy tab didn't work either. I'm also using SFO mod.
  • dvidardvidar Registered Users Posts: 1
    This is still a bug

    Happened to me 2 times on a ME campaign as Carassone

    First time it was due to staying allied with one of the wood elf factions going to war with someone. (Breaking the alliance fixed it, but put me in a **** situation)

    2nd time Im not sure, it is either the diplomatic military alliance with clan angrund and middenland or it is the doomtime notification. Declaring war on Clan Angrund solves the issue, but just breaking the non angression pact does not (I asume they still negotiate military alliance wiht middenland even thou I cant see it?)
    I have tried to continue with declairing war, but I get overun in like 10 turns since everyone joins Clan Angrund and no one joins me so its not a soluition for me.

    Iv spendt hours reading forums, trying different solutions, rolling back to earlier saves in hope to fix the issue and my conclution is that its either certain events that needs to be resolved but the popup does not show or a bug due to diplomacy

    Iv found bug dating all the way back to early 2017, so maybe time to fix this issue CA?
  • fuglefot1fuglefot1 Registered Users Posts: 15
    Bugs when archaon arrives at turn 191...cant end turn or move units...
    Doesnt seem to matter which turn he arrives. I loaded a previous save, and it still happened again,at turn 193 this time. He just spawns when the last stack of chaos invaders are deafeted.

    I run 35 mods including SFO,so i suppose a savegame is useless. (i doubt its any of the mods)

    I`ve researched this for hours now,tried every "trick" out there to get my game going again,and still nothing is solved!

    Can you please find a way to fix this as soon as possible?

    Thank You.
  • LinjoLinjo Registered Users Posts: 8
    Hopefully not necroing a fixed issue, but I had this recently again when the Chaos invasion popped. None of the above helped. However I installed a 'NO Chaos Invasion' mod with my SFO and restarted the autosave. Chaos still popped but the bug is gone. Go figure... :)
  • CrispyGreedoCrispyGreedo Registered Users Posts: 1
    edited December 2019
    This issue is not fixed. Currently unable to get past turn 29 as Ikit Claw without it occurring, so I guess I'll have to try a different Skaven faction and hope I can get them to work. For the record - not running any mods whatsoever, just vanilla TW: WH2, and I've never experienced this bug before. Really disappointed as I was looking forward to slinging Doom-rockets all over!

    EDIT: I was able to get mine unstuck by entering the Faction Summary screen => Records tab, clicking on one of the events from a recent turn, hitting View Event and then backing out of the menu. Not sure if this will work for anyone else but just FYI!
    Post edited by CrispyGreedo on
  • BalsiefenBalsiefen Registered Users Posts: 11
    Just got this bug as Lokhir fellheart on turn 131, ME campaign. Seems to be caused by the Doom Tide event not going into its animation properly.
  • kenny98433kenny98433 Registered Users Posts: 13
    edited October 2020
    This is STILL an issue. I remember this bug from Warhammer 1, seems CA didn't bother to fix it. Currently I'm playing a Wurrzag ME campaign and I'm on turn 38, completely screwed, thanks a lot CA.

    (Edit) Loaded the previous auto save and it seems the "A stranger approaches" event was what made it bug out.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file