Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

SolvedTotal War: Rome II Emperor Edition Will not Launch on Windows 10

Bobobobo17Bobobobo17 Posts: 9Registered Users
edited December 2017 in Rome II Support
Good morning,

I recently got a new PC, with the following specs, AMD Ryzen 5 2500U With Vega Mobile Gfx, 8gb Ram, WINDOWS 10.


After much troubleshooting, I have been unable to play Rome II. When starting the game through the steam library and clicking "play," next to the game it says "running" for a short time, then "syncing," then goes idle again.


Below I will list the steps that I have taken that have not worked so far:

1). Attempted to start up game normally through steam.

2) I attempted to start up the game in compatibility mode (attempted both windows 7 and windows 8 compatibility mode).

3) I attempted to start up steam in compatibility mode (both W7 and W8).

4) I then attempted both steam, and the game in compatibility mode (W7 and 8).

5) I used the "%appdata%" method to delete the Rome 2 file in app data.

6) I uninstalled and reinstalled the game.

7) I set the game to French language, let the update download, then set it back to English.


I have started up other games without a problem with steam so it appears to be an issue with Rome. If anybody could be of assistance, it would be much appreciated!!



Post edited by dge1 on

Comments

  • TallestdavidTallestdavid Junior Member Posts: 8Registered Users
    I have the same issue. any fix yet?
  • Bobobobo17Bobobobo17 Posts: 9Registered Users
    Not yet, I'm still scouring the web for other help, but I posted on here to see if anybody else found a solution!
  • TallestdavidTallestdavid Junior Member Posts: 8Registered Users
    iim doing same. since we have no help lets post whatever we find on here :P team work!
  • Bobobobo17Bobobobo17 Posts: 9Registered Users
    Still need help. I most recently tried: apps & features -> windows features -> legacy components -> Direct play (enabling it). This worked for Age of empires, but still no solution for Rome II. PLEASE HELP!
  • Lord_ChatalotLord_Chatalot Posts: 88Registered Users
    I've found a way, it didn't work after deinstalling it, so I changed the properties of Rome2.exe to start as administrator and launched the game via the Rome2.exe, not steam. This way the launcher doesn't open and the game just opens. I have right now the same problem with Attila, where I had to rename the launcher.exe and start it again via Attila.exe.

    Seems to be a problem caused by the launcher, could maybe be fixed after the holidays.

    Currently you will have to enable/disable mods via user.script

  • Lord_ChatalotLord_Chatalot Posts: 88Registered Users
    Guys, I've found it!

    You have to go to the directory of another TW game (I used Warhammer 2) which works for you, copy all files in the launcher folder, delete all files in the Rome 2 launcher folder, paste the copied files and your good to go.

    This way you basically use the Warhammer 2 launcher for your game, since the Rome 2/Attila doesn't seem to work and you can still disable mods, etc.

    Hope this helps you!
  • Bobobobo17Bobobobo17 Posts: 9Registered Users
    I'll give it a shot. Do we know if the launcher file is the same for all of the TW games? I've got Empire, Rome II and Medieval only.
  • Bobobobo17Bobobobo17 Posts: 9Registered Users
    Hi Guys,

    What I found to work was copying the rome2.exe file to the launcher folder and renaming it launcher.exe. I went back in steam and it started right up.


    Rome2.exe is found in programs-steam-steamapps-common-Total War Rome II.
  • OnhorasOnhoras Posts: 1Registered Users

    Hi Guys,

    What I found to work was copying the rome2.exe file to the launcher folder and renaming it launcher.exe. I went back in steam and it started right up.


    Rome2.exe is found in programs-steam-steamapps-common-Total War Rome II.

    This solution was the good one for me. Thanks Bobobobo17
  • Bobobobo17Bobobobo17 Posts: 9Registered Users
    No problem man. Just trying to spread the word!
  • CornstarchCornstarch Posts: 1Registered Users
    Not to bring up an old thread but I’m having a similar issue. Trying bobobos method but I don’t have a Rome.exe in my folder under steam, steamapps, common etc..

    Any help?
  • vanGennevanGenne Posts: 6Registered Users
    edited January 24
    I want to tag along here, these proposals don't work for my game. If I change the name of Rome2.exe to launcher.exe (or Launcher.exe), the launcher simply thinks I dont have the game installed...

    I posted something earlier on here, no response so far (link). I figured I wouldn't start a new thread with 2 similar threads open..
  • shadow_marshall1shadow_marshall1 Posts: 1Registered Users
    i have the same problem in WINdows 10. Any fix yet or nothing?
  • Bobobobo17Bobobobo17 Posts: 9Registered Users
    Hi Guys,

    To be clear, I copied the rome2.exe file into the folder with the launcher file, then renamed it launcher.exe. I left rome2.exe alone.
  • DominumDominum Posts: 10Registered Users
    edited April 14
    I think i fixed it.
    At leats for me it did.
    I tried de copying rome 2 to launcher and renaming it and nothing.
    Ran rome2 as administrator and nothing.
    Finally it ocurred to me! Disconnecting the pc from the internet! And the game ran!
    There must be something about Steam that is messing up the game, but at least i got it running again.
    Hope it does the yrick for you guys.

    On a final note, CA you really should be solving this problem. Paying costumers shouldnt have to waste hours on figuring out whats wrong with your software.
    Post edited by BillyRuffian on
  • gmingoniegmingonie Posts: 1Registered Users

    Hi Guys,

    What I found to work was copying the rome2.exe file to the launcher folder and renaming it launcher.exe. I went back in steam and it started right up.


    Rome2.exe is found in programs-steam-steamapps-common-Total War Rome II.

    +1 for working! love your work
  • PistachePistache Posts: 1Registered Users
    Dominum said:


    "Finally it ocurred to me! Disconnecting the pc from the internet! And the game ran!
    There must be something about Steam that is messing up the game, but at least i got it running again.
    Hope it does the yrick for you guys."

    After trying all the things here, I came across this and it still didn't work. Did you undo the other things before?? Also, when I start it up from the .exe file, it comes up with this message:

    C:\Windows\WinSxS\x86_microsoft.vc90.crt_1fc8b3b9a1e18e3b_9.0.30729.9279_none_50939ec6bcb7c\MSVCR90.dll is either not designed to run on Windows or it contains an error. Try installing the program again or using the original installation media or contact your system administrator or the software vendor. Error status 0xc000012f.
    I've no clue what to do.

    P.S I'm using Windows 10
Sign In or Register to comment.