Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

Rome 2 (Emperor's Edition) Total War - keeps on crashing randomly during battles

rareboirareboi Posts: 4Registered Users
Greetings

Recently I had once again installed Total War: Rome 2 Emperor's Edition and while the game is running smoothly on my system on high settings (in game preset) - it keeps on crashing randomly during the battles regardless of the graphical settings or number of troops etc...

I don't think so the problem of crashing is because of my system, it isn't the most high-end pc out there but I remember it was more than enough for this game at the launch (when I played without any problems).

I think I'm probably missing some small changes that have been made since I played this game last time.
Changes either made to my computer (software) or the game itself...

My specs are:
Operating System: Windows 7 Professional 64-bit
Processor: Intel(R) Core(TM) i7 CPU 870 @ 2.93GHz (8 CPUs), ~2.9GHz
Memory: 8192MB RAM
DirectX Version: DirectX 11
GPU: NVIDIA GeForce GTX 650 Ti
Sound card: NVIDIA Virtual Audio Device (Wave Extensible) (WDM)

Have any of you experienced similar problems? If so, how did you solve this problem?
Please, any help is appreciated.
Have a great day!
Thank you.

Comments

  • rareboirareboi Posts: 4Registered Users
    PS: I forgot to attach my crash dump file from the latest crash I experienced

    Hope it helps
  • ThorgornThorgorn Posts: 19Registered Users
    I was really surpised to see your only running this on High, then i looked up the video card. It only has 1GB this could cause an issue if the memory runs out whilst you are playing. I see you have around 2GB shared memory but due to it being shared memory and not physical. I would say this is related to only have 1GB of ram for the card. Have you tried lowering the settings?

    Good luck, and hope you get this sorted
Sign In or Register to comment.