Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

[NTW] No response from host - A tale of two routers

nwyllienwyllie Posts: 2Registered Users
POSSIBLE SOLUTION FOUND! See 2/15/2018 update below.

I have tried to play NTW on my desktop gaming computer that goes through an 8-port D-Link router using DD-WRT firmware. I continually got the "No response from host" error every time I tried an internet multiplayer game. I even tried port forwarding. This was a number of years ago. Recently my friend and I tried again, having the same issue. I have a gaming laptop that goes through a different router (DIR-615, factory firmware) and we tried it there and all worked great! However, connecting to the wi-fi off of the 8-port the connection issues were seen for the laptop as well. This isolated the issue to the 8-port router, it would seem. On a whim I removed the port forwarding, and much to my surprise the game worked through 8-port for both the desktop and laptop. Problem solved!

Or so I thought.

Today we tried to play through the 8-port again and the connection problem is back. Ports are still not forwarded, nothing was changed on the router since the time it was working (other than being unplugged and plugged in again).

So I'm looking for ideas of what to try next. Switching the routers is not an option. Neither is hard wiring the desktop to the other router (not only are no ports available, but is on the other side of the house). Oddly enough, the working router connects to the 8-port, which in turn connects to the internet. I'm not a router expert by any means, but I've had some success working with them.

Any help would be appreciated.

Thanks.

1/31/2018 Update: Now it's not working through either router. Odd that at times one router works and at other times (most of the time) it doesn't. I tried adding a router between the 8-port and the desktop, but, of course, that didn't work either.

2/2/2018 Update: I've tried a number of things, none of which have worked.
  • Connected directly to the cable modem, bypassing home network.
  • Booted in safe mode.
  • Connected to a hotspot off my iPhone.
  • Disabled all anti-virus and firewalls.
  • Set the computer IP in my router to DMZ.
  • Verified files through Steam.
  • Turned off Family Mode in Steam
  • Running program in Windows 7 compatibility mode.
  • Running program in Administrator mode.
At this point I'm thinking it has to be an issue with the program, or perhaps Steam. My friend across the country has no problems and is running through Steam. This is pretty weird.

2/15/2018 Update: I may have found a solution! When you have Steam create a desktop shortcut, such as I have, this is a shortcut to a URL: "steam://rungameid/34030". I presume if started from the game library page in Steam the same URL is used. I have instead gone directly to the executable and run that instead. I'm now able to join Internet games! Creating a desktop shortcut for the executable also works, as one would expect.

3/3/2019 - I revisited this recently and found my "solved" tag no longer applies. Probably never did. So I'm still seeking a solution. I'm suspecting my cable modem is the issue somehow. It seems to not allow me to get into administrator mode so I can check settings, and the "status" information is not pointing to anything that might be the problem. Still searching for a solution.
Post edited by nwyllie on

Comments

Sign In or Register to comment.