Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.


Rise of the Tomb Kings bug

GM1986GM1986 Registered Users Posts: 6
In the Mortuary Cult, there is a New Dynasty craft that permits us to get another army, we can do this craft multiple times, like it this said on the orange and round arrows, but even when we got enough resources the awaken button is still inactive and say that we don't have enough resources.


  • diego1714diego1714 Registered Users Posts: 1
    The same thing happens to me.

    Please fix it.
  • losbesaklosbesak Registered Users Posts: 2
    The same thing happens to me too. **** the game experience (we cant win without more army)
  • losbesaklosbesak Registered Users Posts: 2
    The bug : the amount (in gold) is not the good value : it must be multiplied: 10000, 20000, 30000, ...
  • GoutGout Registered Users Posts: 10
    edited January 2018
    Quick Edit - I swear I tried it with 20k Gold, but I can confirm that even though the tip says 10k requirement for the 2nd army, it does finally unlock a second army if you have 20k gold. That said, it still only charges 10k Gold. The canopic jar cost both displays and charges correctly.

    I'm okay with this, so long as it continues. Heck, I wouldn't even mind paying an additional 10k gold per dynasty. Seems fine, I just wasn't saving up because I didn't think it would matter.

    Original post - I am experiencing the same issue. I was able to awaken "A New Dynasty" once. However, no matter how much gold & Jars I possess, awaken is not an option again. I've encountered the bug on all of the TK's campaign's except for Arkhan (who I haven't played much of yet). It's getting frustrating on Mortal Empires, as I can't create enough armies to properly defend my current territory, let alone expand further.

    Please address and fix; it's the sort of bug that makes one consider requesting a full refund for until corrected (I don't play multiplayer, so campaign breaking bugs literally make the DLC not worth the cost). On the flip side, I'm loving the faction. I'd just like to play them without such a breaking bug. Hot fix by next weekend or I'll return through Steam until it is fixed.
    Post edited by Gout on
  • WalfordWalford Registered Users Posts: 2
    I cannot awake even the first army 😭 although I tried twice, twice lost the funds and jars and still not getting my new army 😒
  • kalaxan33kalaxan33 Registered Users Posts: 1
    me too. Can't wake the first army :-( so sad about this.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file