Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Flickering in-game; causes graphics problems [AMD multi-GPU driver problem, Profiles]

Ace42Ace42 Junior MemberPosts: 17Registered Users
edited September 2011 in Total War Eras Support Forum
Hokay; so I had the problem that on the main battle screen some elements flicker and don't render correctly; for example the "mount fuji" end-of-season buttom in the bottom right isn't rendered at all (just a hole where the mountain icon would be, occasionally some horizontal lines) - of the general portraits in the bottom left when clicking on an army or settlement can be replaced by other graphical elements (for example the "way of the sword / way of chi" icons) - or the background of the "advisor" geisha flickers.

I've tried numerous ways to fix it (more on this later) with no luck.

I'm using a Radeon HD6990, and I've tried the following with no progress whatsoever:
1. Installing latest drivers (both catalyst - up to 11.7 now; and the south-bridge).
2. Verifying the game cache in steam (finds 4 files that it needs to reacquire, but doesn't do anything with them)
3. Changing all of the in-game graphics settings (it still happens no matter what graphics quality I set, low, medium, ultra-high, whatever - all the same problem. Changed around all the settings in there, no joy).
4. Changing all of the catalyst global settings (turning on different levels of AA, turning on Morphising AA, setting AA quality to super-sample, turning of AMD optimised tesselation, setting AMD tesselation to application controlled, turn that off again, etc etc,)
5. Disabling Avast's 8 anti-viral shields.
6. Closing Asus's Evo Turbo unlocker and EPU power management - for some reason Shogun 2 was causing their UIs to be restored in the background; but even with them fully exitted, same problem arises.

And a few other things too.

Not sure what is left to try. One other interesting symptom is that the "flickering" goes from being sporadic and a generally mess to very quick even when I turn on Vsync. This makes me think that for some reason the game and the display hardware (the radeon and / or the monitor) aren't synching up properly, or that they're not applying the correct refresh rate (native at 85hz; would be happy to run it at 75hz).

Is there a way to force the game to refresh at 75hz to eliminate this as a possible cause?
Post edited by Ace42 on

Comments

  • IscaranIscaran Tech-Hero. Posts: 4,229Registered Users
    edited July 2011
    AFAIK. It is a common known problem with the crossfire profiles. Same happens in Crysis2. You need to tell the AMD driver crew about it.
    Iscaran

    Hero.

    If you need help with a support request on these boards please read this and follow the instructions.
  • lordmaximus77lordmaximus77 Technical Moderator Leeuwarden, NLPosts: 3,063Registered Users, Moderators, Tech Moderators
    edited August 2011
    Did you happen to only have Catalyst 11.7 or 11.8 Preview installed?

    I've had very similar issues with my 6970 Crossfire setup with those drivers. Reverting back to Catalyst 11.6 (with 11.6 CAP2) solved the issue for me.
    Any fool can make things bigger and more complex. It takes a touch of genius – and a lot of courage – to move in the opposite direction. — Albert Einstein

    viri non urinat in ventum — Anonymous Roman

    TOTAL WAR FORUM: TERMS AND CONDITIONS
  • Ace42Ace42 Junior Member Posts: 17Registered Users
    edited August 2011
    11.7 + cap, you may have hit the problem square on, sounds plausible, as I didn't get to try the game when I was running 11.6. Might test it out when I feel like going through rigmarole of a revert.
  • ArnebjarneArnebjarne Member Posts: 35Registered Users
    edited August 2011
    I have 11,7. Disabled crossfire and everything seems good again. Close to everything with letters and icons was flickering. End turn see through, gong gong for starting matches etc. I suppose roll back on catalyst is the only option. If anyone has other solutions, tips. .
  • Ace42Ace42 Junior Member Posts: 17Registered Users
    edited August 2011
    Yah, I reverted to 11.6 and it works a treat; clearly a problem with crossfire in the later driver versions. Hopefully it will be fixed in either 11.8 final, or 11.9.
  • PyurePyure Junior Member Posts: 2Registered Users
    edited August 2011
    3:00AM: Played Shogun 2; no issues (11.6)
    3:30AM: Downloaded & Installed 11.7
    4:00AM: Played Shogun 2 again
    4:01AM: Cried due to flickering.

    I also have a crossfire setup. (6970x2)
  • Ace42Ace42 Junior Member Posts: 17Registered Users
    edited August 2011
    11.8 works fine for me.
  • BarashBarash Junior Member Posts: 4Registered Users
    edited August 2011
    I can confirm that the new 11.7 and 11.8 catalyst drivers cause the game to become nearly unplayable. These drivers cause the HUD and other various elements such as the sprites that hover over cities and armies to flicker and change their textures to random ones.

    This is the same sort of glitch I had with Empire with this same setup prior to the 11.6 release. The 11.6 drivers plus the newer profiles cleared up the problem with Empire for me by the way. This is caused by having multiple GPUs though, so those of you who aren't having problems obviously are only using one video card.

    Anyway, I'm sitting on 11.6 until AMD gets their act together.
  • Ace42Ace42 Junior Member Posts: 17Registered Users
    edited September 2011
    11.7 was a problem, 11.8 (not preview!) works fine for me. And yes, I am most definitely using a cross-fire setup. Did you install 11.8's CAP2?
  • ArnebjarneArnebjarne Member Posts: 35Registered Users
    edited September 2011
    11.8 was working. Now 11.8 was not. Only changes was windows 7 64 bit updates that I know of. On optional downloads amd drivers I updated the separate crossfire files to 11.8. Now almost works, flickering in starting to fight window, after action report or something. Hope driver 11.9 is better. It's too easy for these companies to blame each other - CA, AMD, Nvidia etc.
Sign In or Register to comment.