Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

SolvedEmpire doesn't launch in Windows 10

DusteuhDusteuh Junior MemberPosts: 7Registered Users
edited June 10 in Empire: Total War
When I try to launch the game (Empire and Napoleon as well), the little steam lauching window open, then close, and nothing else happens.
Post edited by dge1 on

Comments

  • DusteuhDusteuh Junior Member Posts: 7Registered Users
    I tried all things, and nothing works, but I followed EXACTLY these steps, and it works !

    "First, do not uninstall using Steam. Browse to your Empire Folder and go inside the folder, make it empty folder deleting everything inside the Empire folder.

    Second, go to C:\Users\(your user name)\AppData\Roaming\The Creative Assembly\Empire and again, leave the Empire folder, but go inside and delete everything inside.

    Third, on Steam, go to top left corner, click Steam in the menu bar, select exit.

    4) Go to your Steam shortcut, right click, select run as administrator

    5) Go to your games list, right click Empire, select properties. On the window that opens, go to the local files tab, click verify and allow it to verify and download again.

    6) Once complete, on that same Empire Properties window under local files tab, click browse. It will open the window to the empire files, right click your empire.exe, select properties, go to the compatibility tab, set to run under XP, click ok.

    7) Run Empire from your games list. Once it runs, go to options and set your settings. Exit the game. Exit Steam completely, start steam normally (telling Steam to restart will restart in admin mode which is bad to run all the time). Now you should be able to play."
  • SigfordSigford Posts: 1Registered Users
    Thank you very much. Now it works.
  • failtryfailtry Posts: 1Registered Users
    Thanks a lot. Followed step by step works perfectly now!
  • alittleoldmanalittleoldman Posts: 1Registered Users
    Thank you for this tip Dusteuh. Worked for me too! Verifying local files without previously deleting the contents of those directories as you suggest reported all was fine but the game still wouldn't run. Removing them and Steam redownloading them as you suggest worked. Thanks again
  • Avve1000Avve1000 Junior Member Posts: 5Registered Users
    Dosnt work for me, ill redo it again but first try didnt work.
    Have a nice day! //Avve1000 :D
  • Avve1000Avve1000 Junior Member Posts: 5Registered Users
    Avve1000 said:

    Dosnt work for me, ill redo it again but first try didnt work.

    2nd time wont work either, tho it got an improvment. I now can see the loading screen for about 15 sec and then the games shuts down
    Have a nice day! //Avve1000 :D
Sign In or Register to comment.