Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.



CONSINGCONSING Junior MemberRegistered Users Posts: 3
edited April 2018 in Rome II Support
Not sure if this can be just moved or maybe someone would mind explaining why I can't post in the Rome 2 section? Pretty frustrating.

I'm having issues with my mod manager.

I cannot 'tick' any mods without it causing a crash.

I have verified the cache in steam, I have cleanly uninstalled and reinstalled Rome 2 (including manually deleting appdata and the Rome2 file in Steam).

I have manually deleted all mods as well as unsubscribing from them.

Would anyone have any suggestions as to how I can use the launcher to manage mods again? I have save games (not stored in any RTW related directory) which I cannot use because they were created with certain mods active.

Has anyone come across this before? Tha launcher in general works fine and the game runs perfectly. It's not the same issue as when the launcher simply will not launch the game - it just won't let me manage mods.

Any help or advice would be massively appreciated!

Apologies again for posting in the wrong forum.



Sorry, forgot to give any background:

Wanted to play a Sparta grand campaign where the Spartan Hoplites had the same variant mesh as the ones in Wrath of Sparta (aesthetic reasons).

I directly edited the models_rome2.pack (after I made a back up) but the PFM told me I could not save this file unless I converted it to a 'mod' file (which PFM does manually). I did this, ran the game, checked a custom battle to make sure it worked, and saw that there were no unit models at all on the battle map.

I realised that because I converted the models_rome2.pack to a 'mod' file (instead of 'patch') I had to 'tick' it in the mod manager in the launcher. I did this (no issues with the mod manager), and the game ran fine.

I checked out a custom battle again and the unit models were only half complete (helmet, greaves, primary weapon and shield, but no 'body' or armour). I realised that this was probably more hassle than it was worth, so I replaced the modified models_rome2.pack with the back up of the original. I think maybe this is where the problem is coming from, maybe a confusion on the game's part as to what is a mod and what is an original game file, which maybe has carried over despite 3 clean uninstall/reinstalls.

I still wanted to make the variant mesh the same as in Wrath of Sparta, so I just added new lines to an existing unit mod I had created to achieve this. I completed this, and then when I went to select the mod again in the mod manager the above issue appeared.


After leaving it for about half an hour, the mod manager began working again. I could put my own mods from my desktop into the R2 data folder and it worked fine, could tick/untick as much as I wanted.

Went in to the game to check a custom battle just to see if the above Hoplite thing worked and my custom unit appeared but no other units in the game appeared with it, they were invisible.

Checked R2s data folder, realised that models_rome2.pack was missing - it was not installed when I reinstalled it the last time (not sure why). I verified the cache and Steam placed the file in the data folder.

The mod manager is now not working any longer. I'm really quite confused. It really does seem as though my computer/steam/game/God is reading the models_rome2.pack as a mod file or something and it's messing everything up. I have removed the models_rome2.pack file and it works fine, I place it back, and it crashes.

It appears as though this doesn't actually hinder me too much. I can move the file out, select my mods, and move it back in. Not really ideal though and I'm just waiting for it to stop working entirely.

Really not sure how to fix this, anyone have any suggestions at all? Also - the forum still won't allow me to post this in the Rome 2 section. Apologies.

Post edited by dge1 on


  • dge1dge1 Moderator Arkansas, USARegistered Users, Moderators, Knights Posts: 23,709
    edited April 2018
    This link may help explain.

    Note: The problem with you being unable to post had to do with a forum status setting made for your account when the transition was made to the current forum structure. I've corrected it and you should have no further problems with it.
    "The two most common things in the universe are Hydrogen and Stupidity." - Harlan Ellison
    "The right to be heard does not automatically include the right to be taken seriously." - Hubert H. Humphrey
    "Never argue with an idiot. They will only bring you down to their level and beat you with experience.” - George Carlin/Mark Twain
    “Those who cannot remember the past are condemned to repeat it.”–George Santayana, The Life of Reason, 1905.

  • CONSINGCONSING Junior Member Registered Users Posts: 3
    Thanks very much for your quick response dge1!

    I guess that explains it a bit. I've renamed the file entirely now and everything seems to be working properly, seems like a really strange fix but it'll have to do for the time being.

    Thanks for changing the status of my account also - much appreciated.
  • derrk12derrk12 Registered Users Posts: 6
    so my Rome 2 total war is no longer working properly. it starts up and ill start a game but when it brings the land up and shows all the detail. instead i get color distortion, the forest look pink and purple, i have black lines going across the screen, faces are a rainbow color. please help ive tried so much to get this to work.
  • Jesw1991Jesw1991 Registered Users Posts: 6
    Hi guys,

    For the last fortnight, the game loads and I can enter campaign, but will kick me out to desktop after a few minutes with a black screen and the total war cursor visible. I’ve tried drivers, uninstalling windows 8.1 updates, fresh install of rtw2, verified cache, both lobotomies, SFC and DISM checks.

    Nothing has worked, and it’s the only game suffering from this problem, which was not occurring a few weeks back. Anyone having similar problems? Patch 17 no mods.
Sign In or Register to comment.