Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.


SolvedSOLVED: Cannot start game from launcher

peopepeope Registered Users Posts: 4
edited May 2018 in Crashes

Detailed description:
Launcher Starts
When I click "Play" the launcher quits and nothing happens.
Within steam it says "running" and I have to restart steam to fix it.

(Sometimes there is a background process that says Thrones of Britannica something with 13MB of memory)

Reproduction Steps:
Press Play from Steam library
Wait for launcher to load
Press Play
Nothing happens

(When trying launching warhammer I from the same launcher it worked perfectly)

Details of any solutions that have already been attempted:
Updated to latest NVidia Drivers
Run the "thrones.exe"-file directly
Tried to install all the redist
Checked logs but found nothing strange

There is no entry in %appdata%\The Creative Assembly\Roaming\ for this game so I cannot provide more files.
Post edited by Shieldhero90 on


  • peopepeope Registered Users Posts: 4
    EDIT: There is no build-info in the corner since I cannot get past the launcher.
    However from within steam under Local Files it says "Current BuildID: 2733596"
  • peopepeope Registered Users Posts: 4

    The program was blocked by Comodo Firewall.
    The game should have showed an error-message when it couldn't reach the internet.
  • fappinhofappinho Registered Users Posts: 5
    I have the exact same problem right now.

    I have updated my video drivers, updated my Windows (10, 64 bits), verified cache on Steam, but nothing seems to work. Any help would be greatly appreciated.
Sign In or Register to comment.