Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

Rome 2 crashing after update

coopertroop100coopertroop100 Registered Users Posts: 2
After latest windows 10 update Rome Total War 2 won't load a new game. It gets as far as the loading screen for the game after selecting a faction then after about 20 seconds closes back to desktop. Has anyone found a solution?

Comments

  • s4wheads4whead Registered Users Posts: 1
    I'm having the same Issues with the new update, anybody know a solution?
  • HakgovaHakgova Registered Users Posts: 2
    Same here. I did manage to get into the game but when I launched an old game it crashes on next turn.

    I then attempted to create a new game with a different faction. This time as it starts to load.

    All my drivers are up to date. The game has perfectly previous to this.
  • WooldogWooldog Registered Users Posts: 1
    I am having the same problem... existing game will crash to desktop when ending a turn and attempting to create a new game will crash to desktop after selecting a faction. Never had any issues with this game over the years until now... it has been a couple of months since playing but I would expect any updates carried out in that time would be for the better... can anyone advise on how this can be fixed?
  • StrategusIVStrategusIV Registered Users Posts: 1
    I had the same issue of the game exiting to window´s desktop both during a battle about 7 minutes in and when I ended my turn after the window´s update. I did the following two things and have been able to play.
    1. I turned off window´s ¨focus assit which seemed to appear just after my game ended on the desktop.
    2. Uninstalled and re'installed¨Rome2 when my game continued to fail after I checked in valve´s steam the game´s file integrity.

    Sorry I dont have a fix for existing games but I hope this helps. Carpe Diem!
  • Rosco2213Rosco2213 Registered Users Posts: 1
    edited June 13
    Hi

    I had the same problem after the recent windows 10 update. I loaded my recent campaign, finished my turn then the game crashed. I followed StategusIV suggestion with the 'windows focus', it was already off (I DID NOT uninstall and reinstall my game). So i verified my local game files, after a 8.5 mb update everything worked fine. My recent campaign didn't crash after clicking end turn.
    Hopefully this simple solution works for everyone else.

    In case your not sure how to verify your game files, follow these steps:
    -open steam
    -enter your libary
    -right click on Rome 2, enter properties
    -click on local files tab
    -click on 'verify integrity of game files'
    Post edited by Rosco2213 on
  • TheVengeTheVenge Junior Member Registered Users Posts: 44
    I had the same issue, and did nothing with the focus assist. What I did was performed a Local Files integrity check, though, and that seemed to have worked.
Sign In or Register to comment.