Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.


Official Ancestral Update issues thread

CA_EllaCA_Ella Posts: 329Registered Users, Moderators, Administrators, CA Staff Mods, CA Staff, Community Team
edited July 2018 in Ancestral Update Support
Any issues with the Ancestral Update Beta should be reported in this thread, which we will be monitoring closely.


  • intramurosintramuros Posts: 3Registered Users
    edited July 2018
    This is all good, but would it be compatible with Mac? The past couple of DLCs after the political patch weren’t.
  • CA_EllaCA_Ella Posts: 329Registered Users, Moderators, Administrators, CA Staff Mods, CA Staff, Community Team

    This is all good, but would it be compatible with Mac? The past couple of DLCs after the political patch weren’t.

    Unfortunately it isn't Mac compatible.
  • Karl_franz1914Karl_franz1914 Posts: 4Registered Users
    the subtitles in benchmark are not shown correctly and the grass in battles is not rendering correctly when i zoom in and out
  • Lucius_AurelianLucius_Aurelian Posts: 5Registered Users
    edited July 2018
    So i found this "fog" line here (im on the Extreme graphics BTW)

  • Lucius_AurelianLucius_Aurelian Posts: 5Registered Users
    edited July 2018

    I dont know if this is a glitch but the lighting isnt right here shouldnt the guy up front have more light then towards the center? (logic)

  • BenjinBenjin Junior Member Posts: 256Registered Users
    I've got a strange reflection bug occurring with lakes in the Battle of Teutoburg Forest. There's a big, black square showing in the reflection. Not sure if it occurs anywhere else yet, since this is my first time seeing lakes with this patch.

    Currently working on a whole lot more, stay tuned.
  • acroguePatrickacroguePatrick Posts: 332Registered Users
    I'm having issues with launching the game itself. Total War Launcher just won't launch at all.
  • Lucius_AurelianLucius_Aurelian Posts: 5Registered Users
    Here is a better view of the "fog" line

  • WOBUHUIAWOBUHUIA Posts: 10Registered Users
    In this new beta,the minimum thickness of infantry line is only 4.That makes ROME2 more like ToB. Why do you change this? Maybe it should keep the former setting. :)

    And I find the FPS is lower than before ,when it comes to winter in the strategic map. Hope you guys can improve it. ;)
  • MarcusIuniusBrutusMarcusIuniusBrutus Senior Member GermanyPosts: 1,739Registered Users
    Its intended, that spaghetti lines are gone. Unrealistic. ;)
  • ivanculaivancula Posts: 12Registered Users
    edited July 2018
    Admittedly I have and aging pc but some graphical options like water detail now really impact heavly on performance (I'm talking about 15 fps more or less between High and Very High setting). Would it be useful to provide my configuration?

    Also, AA seems to be noticeable only on 8x, but that setting is definetly too taxing for my machine.
    Generally, keeping my previous graphics options, I've seen a dip in performance, with occasional stuttering
  • MigzMigz Senior Member Posts: 316Registered Users
    edited July 2018
    I mostly really like the new graphics changes, so kudos for that!

    But, in a radius around the camera, the ground is much lighter than elsewhere. By raising the camera, the lighter area shrinks until it disappears. It's strange and off putting.

    EDIT: The setting this is linked to is the "Hide Foliage" one. With "Hide Foliage" checked, this light circle goes away.

    Post edited by Migz on
  • acroguePatrickacroguePatrick Posts: 332Registered Users
    No lightening appearing in the naval battles?
  • ivanculaivancula Posts: 12Registered Users
    I just fought a battle in which the enemy reinforcements just stopped marching after a while (they are the blobbed bunch on the left) and just sent me one cavalry unit at a time. They reactivated only when I attacked them.

    Also, there is a minor typo in some intrigue tooltips: "This character is not a ruLLing party member"

  • Necropolitan13Necropolitan13 Junior Member Posts: 38Registered Users
    edited July 2018
    I'm not sure if this is something that happened before this beta, but I'm having a crash upon trying to ambush an army with two of my own. I have two armies next to each other in ambush stance, and the enemy walked into it, so it's my two armies against their one army, but whenever I try to load into the battle the game crashes in the loading screen. I noticed also that the map in the loading screen shows just a small square area as my deployment zone with no apparent enemy deployment zone, so I'm guessing that has something to do with it.
  • PolyperchonPolyperchon Posts: 7Registered Users
    edited July 2018
    I'm currently unable to load the game with the Beta. it comes up with "Failed to Initialize Steam! Are you running Steam?"

    Tried uninstalling and reinstalling.

    Deleting folders and validating. No luck at the moment.

    EDIT: Fixed it by restarting computer after installing.
    Post edited by Polyperchon on
  • Karoten2Karoten2 Posts: 177Registered Users
    edited July 2018
    - The Battle AI does not use chariots properly

    - It is not issue with the Ancestral Update, but slapdash made Nomadic Tribes DLC, all three factions /Massagetae, Roxolani, Royal Scythia/ have same victory conditions, would be better to rewrite
    Post edited by Karoten2 on
  • MeloncatMeloncat Junior Member Posts: 15Registered Users
    The visual update appears to cause problems for TWeak's toolkit. With the beta enabled I experience a fogginess and lack of specular/gloss shine on objects: https://i.imgur.com/7WxK5NUg.png - This is the issue on three pieces of armor/clothing, but it impacts all possible items, whether Vanilla, Empire Divided, or custom.

    I opted out of the visual beta update and loaded TWeak again and that solved the issue.

    Thanks for the hard work!
  • Sir_KoopamanSir_Koopaman Posts: 1Registered Users
    I've tried about five different campaigns in both the Grand Campaign and Empires Divided (as Palmyra), but each campaign freezes after ~20 turns of gameplay when I try to go into the characters tab in order to give my characters skills.
  • thvazthvaz Posts: 22Registered Users
    Got an issue with the sea and parts of UI flickering. Tried changing a lot of settings to no avail.
  • zabricklerzabrickler Posts: 1Registered Users
    Occasionally when I complete a battle my frames drop and I have to force close the game.
  • IelloIello Senior Member Posts: 399Registered Users
    Imperator Augustus campaign: Cleopatra's lost her unique voice again, and erroneously uses generic Greco-Roman female general voice acting. This occurs both when playing as Egypt and when talking to her in diplomacy as another faction.
  • Octavius_5Octavius_5 Senior Member Posts: 272Registered Users
    edited July 2018
    I saw this reported on the Steam forums and I did a quick custom battle to check it out myself. It seems like the Heavy Tower Hepteres ship towers only fire arrows from the starboard (right) side of the ship and no arrows are fired from the port (left) side. I didn't check any of the other tower ships. If this could be looked into that would be great. Thank you very much for all the fixes and improvements with this update. They are all much appreciated.

    Edit: Also in the same custom battle, there seems to be a bug with the enemy deployment where some of the enemy soldiers are deployed outside of their ships in the middle of the ocean...

    Just let me know if you need more information to help troubleshoot.

  • Trajan117Trajan117 Junior Member Posts: 17Registered Users
    It seems that the Ardiaei armies are missing their standards even when I manually change the standard within the army management panel.
  • peacheslambpeacheslamb Posts: 4Registered Users
    edited July 2018
    The knocked_flying animation states seem to be bugged. After getting hit by cavalry or explosive artillery, entities will continue their current animation while flying through the air before transitioning into the lying_down animation states. Tested on sword, spear, and bow infantry so it's probably a missing animation for infantry in general.

    Post edited by peacheslamb on
  • LeonbLeonb Member Posts: 79Registered Users
    I don't know if it was reported but: The Russian language in the game after the patch is a mess missing texts espacially in graphics configuration menu. and in some casses the text is bigger then the place it should be writen in you can see it in the fps counter in benchmark testing of graphic settings...
  • Lucius_AurelianLucius_Aurelian Posts: 5Registered Users
    Name missing???

  • Jedidias1Jedidias1 Posts: 116Registered Users
    edited July 2018

    I got a bug playing with Egypt. I was attacking a town defended by Cyrenaica and they land a ship backward and once it landed the units instead of going back to the sea it just went further into the ground.
    There are some pictures so you can see it.

    Thanks again for the amazing patch and please improve garrison in walled cities and remove automatic ladders!!
  • OndatraOndatra Junior Member Posts: 19Registered Users
    edited July 2018
    Trajan117 said:

    It seems that the Ardiaei armies are missing their standards even when I manually change the standard within the army management panel.

    Yes! Yes! It is an old bug, not beta, but please do something about it, devs.

  • FranciscoIsaDelaFranciscoIsaDela Posts: 1Registered Users
    Please, when I finish ti install the beta the game not start, why that would be?
Sign In or Register to comment.