Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.


Launcher works but game will not start

spoon102spoon102 Registered Users Posts: 1
I can start the launcher successfully, but every time I start the game it sits there busy and the comes up with Thrones of Britannia has stopped working. I can either search for a solution online or close game.

I have just tonight updated my display drivers and tried all the things mentioned in the support pages for this issue. I have only just purchased the game and have never successfully got to the main screen so I cannot give you the version of the game.

I have attached the files below that are required.

I have tried running as admin etc. rebooted machine, removed and reinstalled game twice. Please can you give me some advice on what to do next



Sign In or Register to comment.